summary refs log tree commit diff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-03-20 18:21:47 +0100
committerAndreas Enge <andreas@enge.fr>2023-03-20 18:49:06 +0100
commitccb62d8feb50e2859d7c41429a9e3d9e0fe30bfe (patch)
tree4ab573cee33f277828ad553a22579175b1dda22d /gnu/packages/libreoffice.scm
parent098bd280f82350073e8280e37d56a14162eed09c (diff)
parentf80215c7c4ae5ea0c316f4766e6c05ae4218ede3 (diff)
downloadguix-ccb62d8feb50e2859d7c41429a9e3d9e0fe30bfe.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm29
1 files changed, 6 insertions, 23 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index a80fa4292e..667e93db26 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -888,21 +888,6 @@ of decimal representation of the input floating-point number, the procedure
 commonly called @code{ftoa} or @code{dtoa}.")
     (license license:asl2.0)))
 
-(define-public dragonbox-for-libreoffice
-  (package
-    (inherit dragonbox)
-    (name "dragonbox")
-    (version "1.0.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/jk-jeon/dragonbox")
-                    (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "11h9xhpzp61rfyh1nnca5shzi40skgpdql080k5cb6cfy672s1qz"))))))
-
 (define dtoa
   (origin
     (method url-fetch)
@@ -915,7 +900,7 @@ commonly called @code{ftoa} or @code{dtoa}.")
 (define-public libreoffice
   (package
     (name "libreoffice")
-    (version "7.5.0.3")
+    (version "7.5.1.2")
     (source
      (origin
        (method url-fetch)
@@ -924,7 +909,7 @@ commonly called @code{ftoa} or @code{dtoa}.")
          "https://download.documentfoundation.org/libreoffice/src/"
          (version-prefix version 3) "/libreoffice-" version ".tar.xz"))
        (sha256
-        (base32 "0fq0fxwhbhikqzfl2z5xg2swlnrkg1p8l0shh6qdx9w0msihy4pm"))))
+        (base32 "1dy0lvrvgkr7mbmiag26a38pivcddav8piph7jin1kw4phaxs3cj"))))
     (build-system glib-or-gtk-build-system)
     (arguments
      (list
@@ -970,10 +955,10 @@ commonly called @code{ftoa} or @code{dtoa}.")
                  (string-append "GPGMEPP_CFLAGS=-I"
                                 (search-input-directory inputs
                                                         "include/gpgme++")))
-                (("DRAGONBOX_CFLAGS=-I/usr/include/dragonbox-1.0.0")
+                (("DRAGONBOX_CFLAGS=-I/usr/include/dragonbox-1\\.1\\.3")
                  (string-append "DRAGONBOX_CFLAGS=-I"
                                 (search-input-directory inputs
-                                                        "include/dragonbox-1.0.0"))))
+                                                        "include/dragonbox-1.1.3"))))
 
               ;; /usr/bin/xdg-open doesn't exist on Guix System.
               (substitute* '("shell/source/unix/exec/shellexec.cxx"
@@ -1048,8 +1033,6 @@ commonly called @code{ftoa} or @code{dtoa}.")
                         (dirname
                          (search-input-file %build-inputs
                                             "lib/libboost_system.so")))
-         ;; Avoid a dependency on ucpp.
-         "--with-idlc-cpp=cpp"
          ;; The fonts require an external tarball (crosextrafonts).
          ;; They should not be needed when system fonts are available.
          "--without-fonts"
@@ -1086,7 +1069,7 @@ commonly called @code{ftoa} or @code{dtoa}.")
            clucene
            cups
            dbus-glib
-           dragonbox-for-libreoffice
+           dragonbox
            firebird
            fontconfig
            fontforge
@@ -1100,7 +1083,7 @@ commonly called @code{ftoa} or @code{dtoa}.")
            graphite2
            gst-plugins-base
            gtk+
-           harfbuzz
+           harfbuzz-5
            hunspell
            hyphen
            libabw