summary refs log tree commit diff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-09 00:40:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-12 20:49:12 +0100
commit143fc1a591c552b0464674cfebf8de63bdde7461 (patch)
treea953283acbac14df55693011727c43de9b57804c /gnu/packages/libreoffice.scm
parent127a14e0a638a264108fdba08e83db27716d66f1 (diff)
downloadguix-143fc1a591c552b0464674cfebf8de63bdde7461.tar.gz
gnu: poppler: Update to 0.72.0.
* gnu/packages/patches/poppler-CVE-2018-19149.patch: Delete file.
* gnu/packages/patches/inkscape-poppler-compat3.patch,
gnu/packages/patches/texlive-bin-luatex-poppler-compat.patch,
gnu/packages/patches/texlive-bin-pdftex-poppler-compat.patch,
gnu/packages/patches/texlive-bin-xetex-poppler-compat.patch: New files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/pdf.scm (poppler): Update to 0.72.0.
[replacement]: Remove field.
(poppler/fixed): Remove variable.
* gnu/packages/inkscape.scm (inkscape)[source](patches): Add
'inkscape-poppler-compat{3..5}.patch'.
* gnu/packages/tex.scm (texlive-bin)[source](patches): Update
'texlive-poppler-compat.patch'.  Add
'texlive-bin-{lua,pdf,xe}tex-poppler-compat.patch'.
* gnu/packages/emacs.scm (emacs-pdf-tools)[source](modules, snippet): New
fields.
* gnu/packages/scribus.scm (scribus)[source](patches): Add upstream patch origins.
[source](modules, snippet): New fields.
* gnu/packages/libreoffice.scm (libreoffice)[source](patches): Add three
upstream origins.
[source](snippet, modules): New field.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm42
1 files changed, 40 insertions, 2 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 45e2f63767..451adb0eff 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -984,9 +984,47 @@ converting QuarkXPress file format.  It supports versions 3.1 to 4.1.")
                         (file-name "libreoffice-mdds.patch")
                         (sha256
                          (base32
-                          "0apbmammmp4pk473xiv5vk50r4c5gjvqzf9jkficksvz58q6114f"))))
+                          "0apbmammmp4pk473xiv5vk50r4c5gjvqzf9jkficksvz58q6114f")))
+                      ;; The Poppler API changed rapidly in the versions leading 0.72.
+                      ;; Thus, we need several patches from upstream, each adapting to
+                      ;; different Poppler changes since version 0.68.
+                      (origin
+                        (method url-fetch)
+                        (uri (string-append "https://github.com/LibreOffice/core/commit/"
+                                            "1688a395d05125b83eac6cd5c43f0e3f2f66c491"
+                                            ".patch"))
+                        (file-name "libreoffice-poppler-compat.patch")
+                        (sha256
+                         (base32
+                          "0ia5avmj772mrgs6m4qqf01hs8hzpy3nafidj7w7gqx2zz2s5ih9")))
+                      (origin
+                        (method url-fetch)
+                        (uri (string-append "https://github.com/LibreOffice/core/commit/"
+                                            "5e8bdd9203dd642111c62a6668ee665a20d4ba19"
+                                            ".patch"))
+                        (file-name "libreoffice-poppler-gbool.patch")
+                        (sha256
+                         (base32
+                          "19kc74h5vnk48l2vny8zmm2lkxpwc7g8n9d3wwpg99748dvbmikd")))
+                      (origin
+                        (method url-fetch)
+                        (uri (string-append "https://github.com/LibreOffice/core/commit/"
+                                            "8ff41a26caf51544699863c89598d37d93dc1b21"
+                                            ".patch"))
+                        (file-name "libreoffice-poppler-0.71.patch")
+                        (sha256
+                         (base32
+                          "1dsd0gynjf7d6412dd2sx70xa2s8kld7ibyjdkwg5w9hhi2zxw2f"))))
                 (search-patches "libreoffice-icu.patch"
-                                "libreoffice-glm.patch")))))
+                                "libreoffice-glm.patch")))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           (for-each (lambda (file)
+                       ;; Adjust to renamed function in Poppler 0.72.
+                       (substitute* file (("getCString") "c_str")))
+                     (find-files "sdext/source/pdfimport/xpdfwrapper"))
+           #t))))
     (build-system glib-or-gtk-build-system)
     (native-inputs
      `(("bison" ,bison)