summary refs log tree commit diff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-12-08 12:25:18 +0300
committerAlex Kost <alezost@gmail.com>2016-12-08 12:32:52 +0300
commitcb72d34348998501c0dfa9f6ac4eb64bddd99fbf (patch)
tree14ab1450599bb433f0a59e7ac97980c78170847c /gnu/packages/libreoffice.scm
parenta9c61335c973ee0c29aa0096855a2070de0b34ed (diff)
downloadguix-cb72d34348998501c0dfa9f6ac4eb64bddd99fbf.tar.gz
gnu: libreoffice: Add 'libreoffice' symlink.
* gnu/packages/libreoffice.scm (libreoffice)[arguments]: Adjust
'bin-install' phase to make 'libreoffice' symlink along with 'soffice'.

Co-authored-by: ng0 <ng0@libertad.pw>
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index e02e4f4cdc..279e8e2d22 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -820,14 +820,16 @@ and to return information on pronunciations, meanings and synonyms.")
                    (("./configure") "$(CONFIG_SHELL) ./configure" ))
                  #t)))
            (add-after 'install 'bin-install
-             ;; Create a symlink bin/soffice to the executable script.
+             ;; Create 'soffice' and 'libreoffice' symlinks to the executable
+             ;; script.
              (lambda* (#:key outputs #:allow-other-keys)
                (let* ((out (assoc-ref outputs "out"))
-                      (bin (string-append out "/bin")))
+                      (bin (string-append out "/bin"))
+                      (soffice (string-append
+                                out "/lib/libreoffice/program/soffice")))
                  (mkdir bin)
-                 (symlink
-                   (string-append out "/lib/libreoffice/program/soffice")
-                   (string-append bin "/soffice")))
+                 (symlink soffice (string-append bin "/soffice"))
+                 (symlink soffice (string-append bin "/libreoffice")))
                #t)))
        #:configure-flags
         (list