summary refs log tree commit diff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-16 21:50:00 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-16 22:21:04 +0200
commit57080fea86027c085997b6e320f6777ee9edd495 (patch)
tree7408fc5b105a442b4a6a9baa2844ef8161f2a68a /gnu/packages/libreoffice.scm
parentf678913cfe017da303a4f0ba04897b82f85010bd (diff)
downloadguix-57080fea86027c085997b6e320f6777ee9edd495.tar.gz
gnu: libabw: Propagate inputs.
* gnu/packages/libreoffice.scm (libabw): Move librevenge and libxml2 from
  'inputs' to 'propagated-inputs'.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 23b1e2467c..5739757ce9 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -267,10 +267,11 @@ as Alfresco or Nuxeo.")
        ("gperf" ,gperf)
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)))
-    (inputs
-     `(("boost" ,boost)
-       ("librevenge" ,librevenge)
+    (propagated-inputs ; in Requires or Requires.private field of .pkg
+     `(("librevenge" ,librevenge)
        ("libxml2" ,libxml2)))
+    (inputs
+     `(("boost" ,boost)))
     (arguments
      ;; avoid triggering configure errors by simple inclusion of boost headers
      `(#:configure-flags '("--disable-werror")))