summary refs log tree commit diff
path: root/gnu/packages/librewolf.scm
diff options
context:
space:
mode:
authorIan Eure <ian@retrospec.tv>2024-04-27 17:42:12 -0700
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-04-28 10:01:29 -0400
commit458f704e6d773af17c8eb4a5619ae0ffe0168f2d (patch)
treeaf034ccfe5ef80c2723a3e969c18507b4756599c /gnu/packages/librewolf.scm
parentbaa6d7e04e2b36fe35ddf4f69d842ae253129fae (diff)
downloadguix-458f704e6d773af17c8eb4a5619ae0ffe0168f2d.tar.gz
gnu: librewolf: Update to 125.0.2-1.
* gnu/packages/librewolf.scm (librewolf): Update to 125.0.2-1.  Build with
LLVM/Clang 18; LLVM 13 (the default) segfaults on build.  Minor style tweaks.

Change-Id: Ib515f1596b3ce2dd192baebf1a877b3c2dc8d7e2
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/librewolf.scm')
-rw-r--r--gnu/packages/librewolf.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 1717bad0b5..fa83857c96 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -93,17 +93,17 @@
 ;; upstream.  See the file taskcluster/ci/toolchain/rust.yml at
 ;; https://searchfox.org under the particular firefox release, like
 ;; mozilla-esr102.
-(define rust-librewolf rust) ; 1.60 is the default in Guix, 1.65 is the minimum.
+(define rust-librewolf rust) ; 1.75 is the default in Guix, 1.65 is the minimum.
 
 ;; Update this id with every update to its release date.
 ;; It's used for cache validation and therefore can lead to strange bugs.
 ;; ex: date '+%Y%m%d%H%M%S'
-(define %librewolf-build-id "20240326080003")
+(define %librewolf-build-id "20240427150329")
 
 (define-public librewolf
   (package
     (name "librewolf")
-    (version "124.0.1-1")
+    (version "125.0.2-1")
     (source
      (origin
        (method url-fetch)
@@ -115,7 +115,7 @@
                            version
                            ".source.tar.gz"))
        (sha256
-        (base32 "1sks49nywzhvq5mik4ipm3vyyxv49s9hq6bfyk5d9r6f0nlydllf"))))
+        (base32 "09qzdaq9l01in9h4q14vyinjvvffycha2iyjqj5p4dd5jh6q5zma"))))
     (build-system gnu-build-system)
     (arguments
      (list
@@ -227,7 +227,8 @@
                                                        "\""))))
                                    (find-files "." "Cargo\\.lock$"))
                          (for-each generate-all-checksums
-                                   '("build" "dom/media"
+                                   '("build"
+                                     "dom/media"
                                      "dom/webauthn"
                                      "gfx"
                                      "intl"
@@ -597,8 +598,8 @@ StartupWMClass=Navigator"))
     (native-inputs (list alsa-lib
                          autoconf-2.13
                          `(,rust-librewolf "cargo")
-                         clang
-                         llvm
+                         clang-18
+                         llvm-18
                          m4
                          nasm
                          node-lts