summary refs log tree commit diff
path: root/gnu/packages/libusb.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 15:59:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 15:59:30 -0400
commit990a4822f1cb45c1470fe38cbf17fd7bb54d0088 (patch)
tree1c1ff41c9264fe5af5ee0b8723d1e367e958c051 /gnu/packages/libusb.scm
parent91db77c955cc7ef95dd8b535e40d6b4cf28669ec (diff)
parent3c6e220d8100281074c414a43c1efe9a01b53771 (diff)
downloadguix-990a4822f1cb45c1470fe38cbf17fd7bb54d0088.tar.gz
Merge branch 'staging' into core-updates
Conflicts resolved in:
	gnu/local.mk
	gnu/packages/cran.scm
	gnu/packages/gnome.scm
	gnu/packages/gtk.scm
	gnu/packages/icu4c.scm
	gnu/packages/java.scm
	gnu/packages/machine-learning.scm
	gnu/packages/tex.scm
Diffstat (limited to 'gnu/packages/libusb.scm')
-rw-r--r--gnu/packages/libusb.scm70
1 files changed, 70 insertions, 0 deletions
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index baeebc3bc7..a41b985b3c 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -11,6 +11,7 @@
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Christopher Howard <christopher@librehacker.com>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Jacob Hrbek <kreyren@rixotstudio.cz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -41,6 +42,8 @@
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system python)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages java)
@@ -49,6 +52,7 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages readline)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages xiph))
 
@@ -339,6 +343,72 @@ unmodified CircuitPython code to run on the host computer and interact with
 I2C and SPI devices attached to the USB Hub.")
     (license license:expat)))
 
+(define-public ideviceinstaller
+  (package
+    (name "ideviceinstaller")
+    (version "1.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/libimobiledevice/ideviceinstaller")
+              (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1xp0sjgfx2z19x9mxihn18ybsmrnrcfc55zbh5a44g3vrmagmlzz"))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf automake libtool pkg-config))
+    (inputs (list libimobiledevice libzip))
+    (home-page "https://libimobiledevice.org/")
+    (synopsis "CLI Tool to manage apps and app archives on iOS devices")
+    (description "This package provides an interface to manage IPA format
+files and applications for iOS devices, it's written in C")
+    (license license:gpl2)))
+
+(define-public libirecovery
+  (package
+    (name "libirecovery")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/libimobiledevice/libirecovery")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0p9ncqnz5kb7qisw00ynvasw1hax5qx241h9nwppi2g544i9lbnr"))))
+    (build-system gnu-build-system)
+    (inputs (list readline libusb))
+    (native-inputs (list autoconf automake libtool pkg-config))
+    (home-page "https://libimobiledevice.org/")
+    (synopsis "Communication library with iBoot/iBSS of iOS devices via USB")
+    (description "Libirecovery is a cross-platform library which implements
+communication to iBoot/iBSS found on Apple's iOS devices via USB.")
+    (license license:lgpl2.1)))
+
+(define-public idevicerestore
+  (package
+    (name "idevicerestore")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/libimobiledevice/idevicerestore")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1w7ywp77xc6v4hifi3j9ywrj447vv7fkwg2w26w0lq95f3bkblqr"))))
+    (build-system gnu-build-system)
+    (inputs (list libusb libirecovery libimobiledevice libzip curl zlib))
+    (native-inputs (list autoconf automake libtool pkg-config))
+    (home-page "https://libimobiledevice.org/")
+    (synopsis "CLI tool to restore firmware files to iOS devices")
+    (description "This utility is used to restore bricked or otherwise
+broken iOS devices.")
+    (license license:lgpl3+)))
+
 (define-public libplist
   (package
     (name "libplist")