summary refs log tree commit diff
path: root/gnu/packages/libusb.scm
diff options
context:
space:
mode:
authorChristopher Howard <christopher@librehacker.com>2020-05-02 14:41:00 -0800
committerJakub Kądziołka <kuba@kadziolka.net>2020-05-03 22:43:40 +0200
commit96e399ee30251a0767a45b2bde3f052b25c62714 (patch)
tree53972b1e1aed9a84eaf285eae2740992fa1e37e6 /gnu/packages/libusb.scm
parentf73f4b3a2d7a313a6cb1667bd69205ea4b09f57c (diff)
downloadguix-96e399ee30251a0767a45b2bde3f052b25c62714.tar.gz
gnu: libusb-0.1: fix build failure on newer gcc
* gnu/packages/libusb.scm (libusb-0.1): Disable -Werror.

Signed-off-by: Jakub Kądziołka <kuba@kadziolka.net>
Diffstat (limited to 'gnu/packages/libusb.scm')
-rw-r--r--gnu/packages/libusb.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 01c138cb4e..5f64b33df9 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2017 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
+;;; Copyright © 2020 Christopher Howard <christopher@librehacker.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -113,7 +114,8 @@ version of libusb to run with newer libusb.")
       (sha256
        (base32
         "0i4bacxkyr7xyqxbmb00ypkrv4swkgm0mghbzjsnw6blvvczgxip"))
-      (patches (search-patches "libusb-0.1-disable-tests.patch"))))))
+      (patches (search-patches "libusb-0.1-disable-tests.patch"))))
+    (arguments `(#:configure-flags (list "CFLAGS=-Wno-error")))))
 
 (define-public libusb4java
   ;; There is no public release so we take the latest version from git.