summary refs log tree commit diff
path: root/gnu/packages/lighting.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-10-20 17:45:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-10-20 19:48:33 +0200
commitfa9ac83ec4098ba89c8cc3c9671144fe853fbc06 (patch)
tree89c272f984db95098f60ae1dfa03eed8dfbb3988 /gnu/packages/lighting.scm
parent77aa706ab6695f24abae88f091aa357546eff5d3 (diff)
downloadguix-fa9ac83ec4098ba89c8cc3c9671144fe853fbc06.tar.gz
gnu: ola: Build with protobuf@2.
This follows up commit dd12d4aad02fc83e00e7b09d676aa78bcb7dd476.

* gnu/packages/protobuf.scm (protobuf-2): New variable.
* gnu/packages/lighting.scm (ola)[propagated-inputs]: Use it.
Diffstat (limited to 'gnu/packages/lighting.scm')
-rw-r--r--gnu/packages/lighting.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/lighting.scm b/gnu/packages/lighting.scm
index 7f01cdbc99..ab7069b53b 100644
--- a/gnu/packages/lighting.scm
+++ b/gnu/packages/lighting.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -59,7 +60,9 @@
        ("libuuid" ,util-linux)
        ("zlib" ,zlib)))
     (propagated-inputs
-     `(("protobuf" ,protobuf))) ;; for pkg-config --libs libola
+     ;; Ola 0.10.5 only supports protobuf 2.x, and building it with 3.x breaks.
+     ;; XXX Remove protobuf-2 when it is no longer needed.
+     `(("protobuf" ,protobuf-2))) ;; for pkg-config --libs libola
     (arguments
      `(;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
        ;; build to fail on low memory systems.  We disable that with the