summary refs log tree commit diff
path: root/gnu/packages/links.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-11-02 10:46:56 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-11-02 10:46:56 +0200
commitcb7fed9285e6eb7b9b4a2dd7a6c5b553de86771d (patch)
tree9bab7a5b40fa3860b412411e90cc43fb88b7c531 /gnu/packages/links.scm
parent32efa254a80672bdf5199b8e200764615a3cf68b (diff)
downloadguix-cb7fed9285e6eb7b9b4a2dd7a6c5b553de86771d.tar.gz
gnu: links: Update to 2.12.
* gnu/packages/links.scm (links): Update to 2.12.
  Various whitespace and line length fixes.
Diffstat (limited to 'gnu/packages/links.scm')
-rw-r--r--gnu/packages/links.scm31
1 files changed, 14 insertions, 17 deletions
diff --git a/gnu/packages/links.scm b/gnu/packages/links.scm
index 04abf06991..e0a3da8fe6 100644
--- a/gnu/packages/links.scm
+++ b/gnu/packages/links.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright  2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -31,21 +32,21 @@
 (define-public links
   (package
     (name "links")
-    (version "2.8")
+    (version "2.12")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://links.twibright.com/download/"
                                   name "-" version ".tar.bz2"))
               (sha256
-               (base32 "15h07498z52jfdahzgvkphg1f7qvxnpbyfn2xmsls0d2dwwdll3r"))))
+               (base32 "0knq15yrp60s4jh92aacw8yfc2pcv3bqsw7dba7h5s6ivq8ihhcq"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases (alist-replace
                  'configure
                  (lambda* (#:key outputs #:allow-other-keys)
-                   ;; The tarball uses a very old version of autconf. It doesn't understand
-                   ;; extra flags like `--enable-fast-install', so we need to
-                   ;; invoke it with just what it understand.
+                   ;; The tarball uses a very old version of autconf. It doesn't
+                   ;; understand extra flags like `--enable-fast-install', so
+                   ;; we need to invoke it with just what it understands.
                    (let ((out (assoc-ref outputs "out")))
                      ;; 'configure' doesn't understand '--host'.
                      ,@(if (%current-target-system)
@@ -55,8 +56,7 @@
                      (zero?
                       (system* "./configure"
                                (string-append "--prefix=" out)
-                               "--enable-graphics"
-                               ))))
+                               "--enable-graphics"))))
                  %standard-phases)))
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs `(("zlib" ,zlib)
@@ -69,14 +69,11 @@
     (description "Links is a graphics and text mode web browser, with many
 features including, tables, builtin image display, bookmarks, SSL and more.")
     (home-page "http://links.twibright.com")
-    ;;   The distribution contains a copy of GPLv2
-    ;;   However, the copyright notices simply say: 
+    ;; The distribution contains a copy of GPLv2
+    ;; However, the copyright notices simply say:
     ;; "This file is a part of the Links program, released under GPL."
     ;; Therefore, under the provisions of Section 9, we can choose
-    ;; any version ever published by the FSF
-    ;;   One file (https.c) contains an exception permitting 
-    ;; linking of the program with openssl
-    (license license:gpl1+)))  
-
-
-
+    ;; any version ever published by the FSF.
+    ;; One file (https.c) contains an exception permitting
+    ;; linking of the program with openssl.
+    (license license:gpl1+)))