summary refs log tree commit diff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-26 23:10:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-27 00:54:30 -0400
commit1ae43257347db6e93c6aac37fa622969f245294c (patch)
treeb00b4786d2ec596c47b0fab67b753fcdfa36a048 /gnu/packages/linphone.scm
parent8472c26c254c0381018a3903feb55f31b1ea96f1 (diff)
downloadguix-1ae43257347db6e93c6aac37fa622969f245294c.tar.gz
gnu: liblinphone: Fix the input type of some dependencies.
Libraries being linked to such as libxml2, libiconv and zlib should appear as
'inputs' rather than 'native-inputs'.

* gnu/packages/linphone.scm (liblinphone)[native-inputs]: Move libiconv,
libxml2 and zlib to...
[inputs]: ...here.  Move eudev, python-pystache and python-six to
native-inputs.
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index e8aeabe419..09d5a1121e 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -447,27 +447,28 @@ decoding, and rendering.")
                 ""))
              #t)))))
     (native-inputs
-     `(("dot" ,graphviz)
+     `(("gettext" ,gettext-minimal)
+       ("udev" ,eudev)                  ;for libudev.h
+       ;; For generating the C++ wrappers.
+       ("dot" ,graphviz)
        ("doxygen" ,doxygen)
-       ("gettext" ,gettext-minimal)
-       ("iconv" ,libiconv)
        ("python" ,python)
-       ("xml2" ,libxml2)
-       ("zlib" ,zlib)))
+       ("pystache" ,python-pystache)
+       ("six" ,python-six)))
     (inputs
      `(("bctoolbox" ,bctoolbox)
        ("belcard" ,belcard)
        ("bellesip" ,belle-sip)
        ("bzrtp", bzrtp)
+       ("iconv" ,libiconv)
        ("glib" ,glib)
        ("gtk2" ,gtk+-2)
        ("mediastreamer2" ,mediastreamer2)
        ("notify" ,libnotify)
        ("ortp" ,ortp)
-       ("pystache" ,python-pystache)
-       ("six" ,python-six)
        ("sqlite" ,sqlite)
-       ("udev" ,eudev)))
+       ("xml2" ,libxml2)
+       ("zlib" ,zlib)))
     (synopsis "Belledonne Communications Softphone Library")
     (description "Liblinphone is a high-level SIP library integrating
 all calling and instant messaging features into an unified