summary refs log tree commit diff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-16 10:26:11 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-18 01:31:41 -0400
commit45fd28f76405df30070f161fe79365363d7103b3 (patch)
tree9a963086ab1dfd469622d5aeb418057bf1795124 /gnu/packages/linphone.scm
parentcfd7fc6dd93d47857f450ec4cd49cf2f82b9fae1 (diff)
downloadguix-45fd28f76405df30070f161fe79365363d7103b3.tar.gz
gnu: linphoneqt: Fix crashes.
The application was crashing when clicking on the Preferences menu or the
conference icon.

* gnu/packages/patches/linphoneqt-tabbutton.patch: Add file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/linphone.scm (linphoneqt)[source]: Use it.
[inputs]: Add qtquickcontrols.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 779ddf8cb7..4f142312cc 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -474,7 +474,8 @@ and video calls or instant messaging capabilities to an application.")
         (string-append "https://www.linphone.org/releases/sources/" name
                        "/" name "-" version ".tar.gz"))
        (sha256
-        (base32 "1g2zrr9li0g1hgs6vys06vr98h5dx36z22hx7a6ry231536c002a"))))
+        (base32 "1g2zrr9li0g1hgs6vys06vr98h5dx36z22hx7a6ry231536c002a"))
+       (patches (search-patches "linphoneqt-tabbutton.patch"))))
     (build-system qt-build-system)
     (arguments
      `(#:tests? #f                      ; No test target
@@ -512,6 +513,7 @@ and video calls or instant messaging capabilities to an application.")
        ("qtbase" ,qtbase)
        ("qtdeclarative" ,qtdeclarative)
        ("qtgraphicaleffects" ,qtgraphicaleffects)
+       ("qtquickcontrols" ,qtquickcontrols)
        ("qtquickcontrols2" ,qtquickcontrols2)
        ("qtsvg" ,qtsvg)))
     (synopsis "Desktop client for the Linphone SIP softphone")