summary refs log tree commit diff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-16 14:28:56 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-29 01:17:14 -0400
commit3c7ff0be83973ea37a186e1e9d277e8d02e4f785 (patch)
tree78f493cf0d6001bb81b193ae1b4debc0f0bb98ec /gnu/packages/linphone.scm
parentc2a86746142fd51f53f3006dce5420d23ea36fef (diff)
downloadguix-3c7ff0be83973ea37a186e1e9d277e8d02e4f785.tar.gz
gnu: belle-sip: Enable mDNS support.
* gnu/packages/linphone.scm (belle-sip)[configure-flags]: Enable mDNS support.
[phases]{patch}: Force the detection of avahi.
[inputs]: Add avahi.
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index ec35ad4545..2ca05ac8b9 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -23,6 +23,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages audio)
+  #:use-module (gnu packages avahi)
   #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages crypto)
@@ -493,12 +494,21 @@ including both ARM and x86.")
     (build-system cmake-build-system)
     (outputs '("out" "tester"))
     (arguments
-     `(#:configure-flags
-       (list "-DENABLE_STATIC=NO")      ; Not required
+     `(#:configure-flags (list "-DENABLE_STATIC=NO"
+                               "-DENABLE_MDNS=ON")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch
-           (lambda _
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; Fix mDNS dependency.
+             (let* ((avahi (assoc-ref inputs "avahi")))
+               (substitute* (find-files "." "CMakeLists.txt")
+                 (("find_package\\(DNSSD REQUIRED\\)")
+                  "set(DNSSD_FOUND 1)")
+                 (("\\$\\{DNSSD_INCLUDE_DIRS\\}")
+                  (string-append avahi "/include/avahi-compat-libdns_sd"))
+                 (("\\$\\{DNSSD_LIBRARIES\\}")
+                  "dns_sd")))
              (substitute* "src/CMakeLists.txt"
                ;; ANTLR would use multithreaded DFA generation otherwise,
                ;; which would not be reproducible.
@@ -538,7 +548,8 @@ including both ARM and x86.")
                                ;;"HTTP stack"
                                "Object"))))))))
     (inputs
-     `(("bctoolbox" ,bctoolbox)
+     `(("avahi" ,avahi)
+       ("bctoolbox" ,bctoolbox)
        ("zlib" ,zlib)))
     (synopsis "Belledonne Communications SIP Library")
     (description "Belle-sip is a modern library implementing SIP transport,