summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-07-10 12:12:46 -0400
committerLeo Famulari <leo@famulari.name>2021-07-13 13:15:59 -0400
commit627db5611d3309966d41452b495b291d63821752 (patch)
tree10db994753c91b4cdfd96a1f2dc4ac818f9cc2ad /gnu/packages/linux.scm
parentc111a501f64fc1e00b4efeea7a408a410cf43f61 (diff)
downloadguix-627db5611d3309966d41452b495b291d63821752.tar.gz
gnu: Add linux-libre 5.13.
* gnu/packages/linux.scm (linux-libre-5.13-version, deblob-scripts-5.13,
linux-libre-5.13-pristine-source, linux-libre-5.13-source,
linux-libre-headers-5.13, linux-libre-5.13): New variables.
* gnu/packages/aux-files/linux-libre/5.13-arm.conf,
gnu/packages/aux-files/linux-libre/5.13-arm64.conf,
gnu/packages/aux-files/linux-libre/5.13-i686.conf,
gnu/packages/aux-files/linux-libre/5.13-x86_64.conf: New files.
* Makefile.am (AUX_FILES): Add them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 90e7fa69d1..6f6115cb7e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -355,6 +355,19 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
 
 ;; The current "stable" kernels. That is, the most recently released major
 ;; versions that are still supported upstream.
+(define-public linux-libre-5.13-version "5.13.1")
+(define deblob-scripts-5.13
+  (linux-libre-deblob-scripts
+   linux-libre-5.13-version
+   (base32 "1mhc215a1y8bxip2f0sqmyl0rf7cgw22cmg26hg9x0pfm9li2c95")
+   (base32 "1b4rsx7g0iximrmbih22z0r4mghhm0hqhv83vmxg577c8915fzp1")))
+(define-public linux-libre-5.13-pristine-source
+  (let ((version linux-libre-5.13-version)
+        (hash (base32 "140a9ngzlarin84mnnwgx6z3ckw431d578aixxl60ll5853gdakj")))
+   (make-linux-libre-source version
+                            (%upstream-linux-source version hash)
+                            deblob-scripts-5.13)))
+
 (define-public linux-libre-5.12-version "5.12.16")
 (define deblob-scripts-5.12
   (linux-libre-deblob-scripts
@@ -477,6 +490,14 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (patches (append (origin-patches source)
                      patches))))
 
+(define-public linux-libre-5.13-source
+  (source-with-patches linux-libre-5.13-pristine-source
+                       (list %boot-logo-patch
+                             %linux-libre-arm-export-__sync_icache_dcache-patch
+                             ;; Pinebook Pro patch to fix LCD display
+                             (search-patch
+                              "linux-libre-arm64-generic-pinebook-lcd.patch"))))
+
 (define-public linux-libre-5.12-source
   (source-with-patches linux-libre-5.12-pristine-source
                        (list %boot-logo-patch
@@ -592,6 +613,10 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (description "Headers of the Linux-Libre kernel.")
     (license license:gpl2)))
 
+(define-public linux-libre-headers-5.13
+  (make-linux-libre-headers* linux-libre-5.13-version
+                             linux-libre-5.13-source))
+
 (define-public linux-libre-headers-5.12
   (make-linux-libre-headers* linux-libre-5.12-version
                              linux-libre-5.12-source))
@@ -891,6 +916,12 @@ It has been modified to remove all non-free binary blobs.")
 ;;; Generic kernel packages.
 ;;;
 
+(define-public linux-libre-5.13
+  (make-linux-libre* linux-libre-5.13-version
+                     linux-libre-5.13-source
+                     '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
+                     #:configuration-file kernel-config))
+
 (define-public linux-libre-5.12
   (make-linux-libre* linux-libre-5.12-version
                      linux-libre-5.12-source