summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-05-15 11:19:05 -0700
committerHilton Chain <hako@ultrarare.space>2023-08-24 12:44:46 +0800
commit160f78a4d92205df986ed9efcce7d3aac188cb24 (patch)
tree4f786b6f7978827a93501b7d7193eeb8ea1f5c48 /gnu/packages/linux.scm
parent63b2d9a8f1c5251d72d44a36929b0cdf19533971 (diff)
downloadguix-160f78a4d92205df986ed9efcce7d3aac188cb24.tar.gz
gnu: lsscsi: Move to (gnu packages scsi).
* gnu/packages/linux.scm (lsscsi): Move to...
* gnu/packages/scsi.scm (lsscsi): ... here.
(sg3-utils)[license]: Use license: prefix.
(libiscsi)[license]: Likewise.

Signed-off-by: Hilton Chain <hako@ultrarare.space>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm21
1 files changed, 0 insertions, 21 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index cc6865f0c6..ca223aea37 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3122,27 +3122,6 @@ early boot when entropy may be low, especially in virtualised environments.")
     (license (list license:bsd-3        ; or
                    license:gpl2+))))
 
-(define-public lsscsi
-  (package
-    (name "lsscsi")
-    (version "0.32")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append
-                   "http://sg.danny.cz/scsi/lsscsi-" version ".tar.xz"))
-             (sha256
-              (base32
-               "0jp458m2b3wckr18qkln69i01152qlwz33zm49103lq8fgx0n6d4"))))
-    (build-system gnu-build-system)
-    (synopsis "Lists information about SCSI or NVMe devices in Linux")
-    (home-page "https://sg.danny.cz/scsi/lsscsi.html")
-    (description
-     "@command{lsscsi} lists SCSI logical units or SCSI targets.  It can
-also list NVMe namespaces or controllers and show the relationship between a
-device's primary node name, its SCSI generic (sg) node name and its kernel
-name.")
-    (license license:gpl2)))
-
 (define-public ebtables
   (package
     (name "ebtables")