summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-12 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-12 02:00:01 +0200
commitffbe69c4c3a232363be79012ccbc2c4f3cb46115 (patch)
treeafb9501825d42be24939e3ed0c404f8c76a036aa /gnu/packages/linux.scm
parentf89822cd25cefbbc24138d48f6585a6df0f6a5a1 (diff)
downloadguix-ffbe69c4c3a232363be79012ccbc2c4f3cb46115.tar.gz
gnu: btrfs-progs: Fix tests.
* gnu/packages/linux.scm (btrfs-progs)[native-inputs]: Add libaio,
liburing, and util-linux.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e80ca436b6..d7a80ab491 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5632,10 +5632,12 @@ and copy/paste text in the console and in xterm.")
                      ("python-sphinx" ,python-sphinx)
                      ;; For tests.
                      ("acl" ,acl)
-                     ("which" ,which)
                      ("dmsetup" ,lvm2)
-                     ;; The tests need 'grep' with perl regexp support.
-                     ("grep" ,grep)))
+                     ("grep" ,grep)     ; need Perl regexp support
+                     ("libaio" ,libaio)
+                     ("liburing" ,liburing)
+                     ("util-linux" ,util-linux) ; for fallocate
+                     ("which" ,which)))
     (home-page "https://btrfs.wiki.kernel.org/index.php/Main_Page")
     (synopsis "Create and manage btrfs copy-on-write file systems")
     (description "Btrfs is a @dfn{copy-on-write} (CoW) file system for Linux