summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-05-06 03:58:48 -0400
committerMark H Weaver <mhw@netris.org>2019-05-10 00:00:49 -0400
commitb40a36baff61793e5e227e1f0c6f42ea2ca4e886 (patch)
tree5dcb741349251811131b327dbd9c81dec86df41a /gnu/packages/linux.scm
parent3d8033af420c36ff270f7e3a343eade5d748fa45 (diff)
downloadguix-b40a36baff61793e5e227e1f0c6f42ea2ca4e886.tar.gz
gnu: linux-libre: Update to 5.1.
* gnu/packages/linux.scm (%linux-libre-version): Update to 5.1.
(%linux-libre-hash): Update hash.
(%linux-libre-5.0-patches): Rename to ...
(%linux-libre-5.1-patches): ... this.
(linux-libre, linux-libre-arm-generic, linux-libre-arm-veyron)
(linux-libre-arm-omap2plus): Use %linux-libre-5.1-patches.
(vhba-module): Move definition below the kernel packages.
* gnu/packages/aux-files/linux-libre/5.0-arm-veyron.conf,
gnu/packages/aux-files/linux-libre/5.0-arm.conf,
gnu/packages/aux-files/linux-libre/5.0-arm64.conf,
gnu/packages/aux-files/linux-libre/5.0-i686.conf,
gnu/packages/aux-files/linux-libre/5.0-x86_64.conf: Delete files.
* gnu/packages/aux-files/linux-libre/5.1-arm-veyron.conf,
gnu/packages/aux-files/linux-libre/5.1-arm.conf,
gnu/packages/aux-files/linux-libre/5.1-arm64.conf,
gnu/packages/aux-files/linux-libre/5.1-i686.conf,
gnu/packages/aux-files/linux-libre/5.1-x86_64.conf: New files.
* Makefile.am (AUX_FILES): Adjust accordingly.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm58
1 files changed, 29 insertions, 29 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4e08bd0ae3..0502eaa63a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -426,10 +426,10 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
 It has been modified to remove all non-free binary blobs.")
     (license license:gpl2)))
 
-(define %linux-libre-version "5.0.14")
-(define %linux-libre-hash "1y9wfn814h8p9k75nh1h42m35qbz9jw0kzp7bvjmrw9gvwf98cdg")
+(define %linux-libre-version "5.1")
+(define %linux-libre-hash "153vd48k98pm8556hfnvs9za77n91gwv0dvv5hnzzhwl9l6jxbcl")
 
-(define %linux-libre-5.0-patches
+(define %linux-libre-5.1-patches
   (list %boot-logo-patch
         %linux-libre-arm-export-__sync_icache_dcache-patch))
 
@@ -437,31 +437,9 @@ It has been modified to remove all non-free binary blobs.")
   (make-linux-libre %linux-libre-version
                     %linux-libre-hash
                     '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux")
-                    #:patches %linux-libre-5.0-patches
+                    #:patches %linux-libre-5.1-patches
                     #:configuration-file kernel-config))
 
-(define-public vhba-module
-  (package
-    (name "vhba-module")
-    (version "20190410")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "http://downloads.sourceforge.net/cdemu/vhba-module/vhba-module-"
-                    version ".tar.bz2"))
-              (sha256
-               (base32
-                "1513hq130raxp9z5grj54cwfjfxj05apipxg425j0zicii59a60c"))))
-    (build-system linux-module-build-system)
-    (arguments
-     ;; TODO: No tests?
-     `(#:tests? #f))
-    (home-page "https://cdemu.sourceforge.io/")
-    (synopsis "Kernel module that emulates SCSI devices")
-    (description "VHBA module provides a Virtual (SCSI) HBA, which is the link
-between the CDemu userspace daemon and linux kernel.")
-    (license license:gpl2+)))
-
 (define %linux-libre-4.19-version "4.19.41")
 (define %linux-libre-4.19-hash "0lf1w72y4qkrg57qd78zs16r658qaqzwly0y9195nf7bdwqzb03v")
 
@@ -507,7 +485,7 @@ between the CDemu userspace daemon and linux kernel.")
   (make-linux-libre %linux-libre-version
                     %linux-libre-hash
                     '("armhf-linux")
-                    #:patches %linux-libre-5.0-patches
+                    #:patches %linux-libre-5.1-patches
                     #:defconfig "multi_v7_defconfig"
                     #:extra-version "arm-generic"))
 
@@ -515,7 +493,7 @@ between the CDemu userspace daemon and linux kernel.")
   (make-linux-libre %linux-libre-version
                     %linux-libre-hash
                     '("armhf-linux")
-                    #:patches %linux-libre-5.0-patches
+                    #:patches %linux-libre-5.1-patches
                     #:configuration-file kernel-config-veyron
                     #:extra-version "arm-veyron"))
 
@@ -538,7 +516,7 @@ between the CDemu userspace daemon and linux kernel.")
   (make-linux-libre %linux-libre-version
                     %linux-libre-hash
                     '("armhf-linux")
-                    #:patches %linux-libre-5.0-patches
+                    #:patches %linux-libre-5.1-patches
                     #:defconfig "omap2plus_defconfig"
                     #:extra-version "arm-omap2plus"))
 
@@ -557,6 +535,28 @@ between the CDemu userspace daemon and linux kernel.")
                     #:defconfig "omap2plus_defconfig"
                     #:extra-version "arm-omap2plus"))
 
+(define-public vhba-module
+  (package
+    (name "vhba-module")
+    (version "20190410")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://downloads.sourceforge.net/cdemu/vhba-module/vhba-module-"
+                    version ".tar.bz2"))
+              (sha256
+               (base32
+                "1513hq130raxp9z5grj54cwfjfxj05apipxg425j0zicii59a60c"))))
+    (build-system linux-module-build-system)
+    (arguments
+     ;; TODO: No tests?
+     `(#:tests? #f))
+    (home-page "https://cdemu.sourceforge.io/")
+    (synopsis "Kernel module that emulates SCSI devices")
+    (description "VHBA module provides a Virtual (SCSI) HBA, which is the link
+between the CDemu userspace daemon and linux kernel.")
+    (license license:gpl2+)))
+
 
 ;;;
 ;;; Pluggable authentication modules (PAM).