summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-02-24 16:15:56 -0500
committerLeo Famulari <leo@famulari.name>2023-03-06 18:15:07 -0500
commite6ed6ab7f3111addda6cda886320ab35e7577e40 (patch)
treebfbfd62a9f01c158fac1fc18718e2bee2bbe0df0 /gnu/packages/linux.scm
parentad66469b240cdf487b6deddff145ccc7091ca529 (diff)
downloadguix-e6ed6ab7f3111addda6cda886320ab35e7577e40.tar.gz
gnu: Add linux-libre 6.2.
* gnu/packages/linux.scm (linux-libre-6.2-version, linux-libre-6.2-gnu-revision,
deblob-scripts-6.2, linux-libre-6.2-pristine-source, linux-libre-6.2-source,
linux-libre-headers-6.2, linux-libre-6.2): New variables.
* gnu/packages/aux-files/linux-libre/6.2-arm.conf,
gnu/packages/aux-files/linux-libre/6.2-arm64.conf,
gnu/packages/aux-files/linux-libre/6.2-i686.conf,
gnu/packages/aux-files/linux-libre/6.2-x86_64.conf: New files.
* Makefile.am (AUX_FILES): Add them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e3acaeb60b..8c025d6b4b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -481,6 +481,21 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
 ;; The current "stable" kernels. That is, the most recently released major
 ;; versions that are still supported upstream.
 
+(define-public linux-libre-6.2-version "6.2.2")
+(define-public linux-libre-6.2-gnu-revision "gnu")
+(define deblob-scripts-6.2
+  (linux-libre-deblob-scripts
+   linux-libre-6.2-version
+   linux-libre-6.2-gnu-revision
+   (base32 "0psa6vqnq3iadjg76hl7aly7scm0ayimbjnzh4fdx78bjb9ypqw3")
+   (base32 "1x91kmprjgs3ypmvmjffm2f2sshj704znhjrdz1w0n4scy1fbl4b")))
+(define-public linux-libre-6.2-pristine-source
+  (let ((version linux-libre-6.2-version)
+        (hash (base32 "1c5zxkpahg92as14h8j2yilc4302w6g98zkjawsfh68fpfi5a9y1")))
+   (make-linux-libre-source version
+                            (%upstream-linux-source version hash)
+                            deblob-scripts-6.2)))
+
 (define-public linux-libre-6.1-version "6.1.15")
 (define-public linux-libre-6.1-gnu-revision "gnu")
 (define deblob-scripts-6.1
@@ -602,6 +617,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (patches (append (origin-patches source)
                      patches))))
 
+(define-public linux-libre-6.2-source
+  (source-with-patches linux-libre-6.2-pristine-source
+                       (list %boot-logo-patch
+                             %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
 (define-public linux-libre-6.1-source
   (source-with-patches linux-libre-6.1-pristine-source
                        (list %boot-logo-patch
@@ -713,6 +733,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (description "Headers of the Linux-Libre kernel.")
     (license license:gpl2)))
 
+(define-public linux-libre-headers-6.2
+  (make-linux-libre-headers* linux-libre-6.2-version
+                             linux-libre-6.2-gnu-revision
+                             linux-libre-6.2-source))
+
 (define-public linux-libre-headers-6.1
   (make-linux-libre-headers* linux-libre-6.1-version
                              linux-libre-6.1-gnu-revision
@@ -1051,6 +1076,14 @@ Linux kernel.  It has been modified to remove all non-free binary blobs.")
 ;;; Generic kernel packages.
 ;;;
 
+(define-public linux-libre-6.2
+  (make-linux-libre* linux-libre-6.2-version
+                     linux-libre-6.2-gnu-revision
+                     linux-libre-6.2-source
+                     '("x86_64-linux" "i686-linux" "armhf-linux"
+                       "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
+                     #:configuration-file kernel-config))
+
 (define-public linux-libre-6.1
   (make-linux-libre* linux-libre-6.1-version
                      linux-libre-6.1-gnu-revision