summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-15 02:50:58 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-15 09:57:17 +0200
commita756fa5ac06ad9934c6efcb9c5fe881834e94e52 (patch)
treeec92eb092a29f744a156da81eca2fe63d21072e7 /gnu/packages/linux.scm
parent14b0c49670241c0703c120eebc8a7252ce55cad4 (diff)
downloadguix-a756fa5ac06ad9934c6efcb9c5fe881834e94e52.tar.gz
gnu: light: Update to 1.1.
* gnu/packages/linux.scm (light): Update to 1.1.
[source]: Switch to GIT-FETCH.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8be3634b0e..dbf3ab3507 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4036,23 +4036,23 @@ monitoring tools for Linux.  These include @code{mpstat}, @code{iostat},
 (define-public light
   (package
     (name "light")
-    (version "1.0")
+    (version "1.1")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/haikarainen/" name
-                                  "/archive/v" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/haikarainen/light")
+                    (commit version)))
               (sha256
                (base32
-                "0r5gn6c0jcxknzybl6059dplxv46dpahchqq4gymrs7z8bp0hilp"))
-              (file-name (string-append name "-" version ".tar.gz"))))
+                "1qra8yzsga29bxlvq63v1db071a1xdji7i60p4kzrciidm1206js"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f ; no tests
+     '(#:tests? #f                      ; no tests
        #:make-flags (list "CC=gcc"
                           (string-append "PREFIX=" %output))
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure)
+         (delete 'configure)            ; no configure script
          (add-after 'unpack 'patch-makefile
            (lambda _
              (substitute* "Makefile" (("chown") "#")))))))