summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-31 01:25:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-31 04:06:08 +0200
commit02052b2c9b37af399f36179a8341585b30976650 (patch)
tree22f329362d857ad50751ed5a25ed7b53ed66c381 /gnu/packages/linux.scm
parent0bea8ebe20158b5a957c6afb5799ee9d86f8375f (diff)
downloadguix-02052b2c9b37af399f36179a8341585b30976650.tar.gz
gnu: hdparm: Expand synopsis and description.
* gnu/packages/linux.scm (hdparm)[synopsis, description]: Add some more
common uses, more examples, and more objective information.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a6b3614bc2..7a9ecf0a00 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2286,10 +2286,18 @@ thanks to the use of namespaces.")
        #:phases (alist-delete 'configure %standard-phases)
        #:tests? #f))  ; no test suite
     (home-page "https://sourceforge.net/projects/hdparm/")
-    (synopsis "Tune hard disk parameters for high performance")
-    (description
-     "Get/set device parameters for Linux SATA/IDE drives.  It's primary use
-is for enabling irq-unmasking and IDE multiple-mode.")
+    (synopsis "View and tune ATA disk drive parameters")
+    (description
+     "@command{hdparm} is a command-line utility to control ATA controllers and
+disk drives.  It can increase performance and/or reliability by careful tuning
+of hardware settings like power and acoustic management, DMA modes, and caching.
+It can also display detailed device information, or be used as a simple
+performance benchmarking tool.
+
+@command{hdparm} provides a command line interface to various Linux kernel
+interfaces provided by the SATA/ATA/SAS @code{libata} subsystem, and the older
+IDE driver subsystem.  Many external USB drive enclosures with @dfn{SCSI-ATA
+Command Translation} (SAT) are also supported.")
     (license (license:non-copyleft "file://LICENSE.TXT"))))
 
 (define-public rfkill