summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:07 +0200
commite0c434ee729f3275c501512f746facc13e1f956e (patch)
tree979ac109d6e1d4b4e0205b624678d485a52733ee /gnu/packages/linux.scm
parent4267580a53e76e1ebbbe3ace7fcb3baa7620cb6f (diff)
downloadguix-e0c434ee729f3275c501512f746facc13e1f956e.tar.gz
gnu: tpacpi-bat: Fix cross-compilation.
* gnu/packages/linux.scm (tpacpi-bat)[arguments]: Use SEARCH-INPUT-FILE.
[inputs]: Add coreutils-minimal.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7f9a835d5f..f3b52b0331 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6373,10 +6373,10 @@ from userspace.")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'refer-to-inputs
-           (lambda _
+           (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "tpacpi-bat"
                (("cat ")
-                (format #f "~a " (which "cat")))
+                (string-append (search-input-file inputs "bin/cat") " "))
                ;; tpacpi-bat modprobes the acpi_call kernel module if it's not
                ;; loaded.  That's the administrator's prerogative; disable it.
                (("system \"(modprobe .*)\"" _ match)
@@ -6397,7 +6397,8 @@ from userspace.")
                              (copy-recursively file target)))
                          (list "battery_asl" "examples" "README.md"))))))))
     (inputs
-     (list perl))
+     (list coreutils-minimal
+           perl))
     (home-page "https://github.com/teleshoes/tpacpi-bat")
     (synopsis "ThinkPad battery charge controller")
     (description