summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-14 02:00:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-14 02:01:32 +0200
commit338f5428d6ca1a76a80e8378650d8b8b5e0600d4 (patch)
tree147c9d088b84d7e2b1c91f329f84ce61abe7add5 /gnu/packages/linux.scm
parent0ac65c8bed7e8f65ece3ae8f5fa2e7c0e4b027d6 (diff)
downloadguix-338f5428d6ca1a76a80e8378650d8b8b5e0600d4.tar.gz
gnu: singularity: Refer to egrep.
* gnu/packages/linux.scm (singularity)[arguments]: Rename
‘patch-reference-to-squashfs-tools’ to ‘patch-references’ and add egrep.

Reported by slimjim on #guix.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9fa7d0cd54..80f546e056 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3937,12 +3937,18 @@ thanks to the use of namespaces.")
      `(#:configure-flags '("--localstatedir=/var")
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch-reference-to-squashfs-tools
+         (add-after 'unpack 'patch-references
            (lambda _
              (substitute* "libexec/cli/build.exec"
                (("if ! singularity_which mksquashfs") "if 0")
                (("if ! mksquashfs")
                 (string-append "if ! " (which "mksquashfs"))))
+             (substitute* (list "libexec/cli/help.exec"
+                                "libexec/bootstrap-scripts/functions"
+                                "libexec/bootstrap-scripts/post.sh"
+                                "libexec/functions")
+               (("egrep ")
+                (string-append (which "egrep") " ")))
              #t))
          (add-after 'install 'set-PATH
            (lambda* (#:key inputs outputs #:allow-other-keys)