summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-09 11:58:45 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-09 17:59:36 +0200
commitde781c05e7dafde6468d371a8e34502b6930fe0a (patch)
treecc7ce163ab05895df1fb0383c85ec30036ba6015 /gnu/packages/linux.scm
parent334bd08c425efe9827d6baed415e7651a957e497 (diff)
downloadguix-de781c05e7dafde6468d371a8e34502b6930fe0a.tar.gz
gnu: util-linux: Remove static library reference from '.la' files.
* gnu/packages/linux.scm (util-linux)[arguments]: Substitute all '.la' files.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fc071a1338..dad5ba97b6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -645,7 +645,14 @@ providing the system administrator with some help in common tasks.")
                                      (rename-file file
                                                   (string-append static "/"
                                                                  file)))
-                                   (find-files "lib" "\\.a$")))
+                                   (find-files "lib" "\\.a$"))
+
+                         ;; Remove references to the static library from the '.la'
+                         ;; files so that Libtool does the right thing when both
+                         ;; the shared and static library is available.
+                         (substitute* (find-files "lib" "\\.la$")
+                           (("old_library=.*") "old_library=''\n")))
+
                        #t))))))
     (inputs `(("zlib" ,zlib)
               ("ncurses" ,ncurses)