summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-10-11 16:56:36 +0200
committerMarius Bakke <marius@gnu.org>2020-10-13 23:48:15 +0200
commit9e1f5a263e4f6df4d075901c9b58a56f80c8b452 (patch)
tree1273d568ad16658a3876db10d2ceffe3335f46be /gnu/packages/linux.scm
parentbb7c3d5aa3fceb08b0cc6403908bf8731d163745 (diff)
downloadguix-9e1f5a263e4f6df4d075901c9b58a56f80c8b452.tar.gz
gnu: libcap: Make 'libcap/next' the default libcap.
* gnu/packages/avahi.scm (avahi)[inputs]: Refer to LIBCAP-2.31 instead of LIBCAP.
* gnu/packages/base.scm (coreutils)[inputs]: Likewise.
* gnu/packages/linux.scm (libcap): Rename to ...
(libcap-2.31): ... this.
(libcap/next): Rename to ...
(libcap): ... this.
(libcap/next): Define as deprecated alias for LIBCAP.
(fakeroot)[inputs]: Change from LIBCAP/NEXT to LIBCAP.
* gnu/packages/ntp.scm (chrony, ntp)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a1a482f290..293b873fc2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -157,6 +157,7 @@
   #:use-module (guix store)
   #:use-module (guix monads)
   #:use-module (guix utils)
+  #:use-module (guix deprecation)    ;for libcap/next
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-2)
   #:use-module (srfi srfi-26)
@@ -2404,7 +2405,7 @@ network hardware types (plipconfig, slattach) and advanced aspects of IP
 configuration (iptunnel, ipmaddr).")
       (license license:gpl2+))))
 
-(define-public libcap
+(define-public libcap-2.31
   (package
     (name "libcap")
     (version "2.31")
@@ -2443,11 +2444,12 @@ Linux-based operating systems.")
     ;; License is BSD-3 or GPLv2, at the user's choice.
     (license license:gpl2)))
 
-;; libcap 2.31 causes problems for 'fakeroot', so provide this newer variant.
+;; libcap 2.31 has problems with newer kernels, so provide this newer variant.
+;; Keep the old libcap around to avoid rebuilding 'coreutils' and 'avahi'.
 ;; To be merged with libcap on the next rebuild cycle.
-(define-public libcap/next
+(define-public libcap
   (package
-    (inherit libcap)
+    (inherit libcap-2.31)
     (version "2.34")
     (source (origin
               (method url-fetch)
@@ -2458,6 +2460,9 @@ Linux-based operating systems.")
                (base32
                 "048n1gy2p48vl9hkrr9wymfxxcpwj2aslz2bv79nhl4m2lhd9kdf"))))))
 
+(define-deprecated libcap/next libcap)
+(export libcap/next)
+
 (define-public bridge-utils
   (package
     (name "bridge-utils")
@@ -7076,7 +7081,7 @@ the superuser to make device nodes.")
        ("xz" ,xz)))
     (inputs
      `(("acl" ,acl)
-       ("libcap" ,libcap/next)
+       ("libcap" ,libcap)
        ("util-linux" ,util-linux)
        ("sed" ,sed)
        ("coreutils" ,coreutils)))