summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-14 13:19:06 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 13:19:06 +0100
commitd594963856690f1aacf228c8a83e406d33bc44ce (patch)
tree3d6ae2d7b5ea7298cb0d6953d986ebfd04542520 /gnu/packages/linux.scm
parentf77ab2abdfd55a38fcbb0e8ebcc4871ab4986bdc (diff)
downloadguix-d594963856690f1aacf228c8a83e406d33bc44ce.tar.gz
gnu: eudev: Remove bugfix variant.
* gnu/packages/linux.scm (eudev/btrfs-fix): Remove variable.
(eudev)[arguments]: Add phase patch-bindir-in-btrfs-rules.
* gnu/services/base.scm (<udev-configuration>, udev-service): Refer to EUDEV
instead of EUDEV/BTRFS-FIX.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm30
1 files changed, 10 insertions, 20 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 04788d2f8a..b0600642d5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2871,6 +2871,16 @@ to the in-kernel OOM killer.")
                                (or native-inputs inputs) "xsltproc")
                                "/bin/xsltproc")))
             #t))
+         (add-before 'configure 'patch-bindir-in-btrfs-rules
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; The "@bindir@" substitution incorrectly expands to a literal
+             ;; "${exec_prefix}" (see <https://bugs.gnu.org/39926>).  Work
+             ;; around it.
+             (let ((out (assoc-ref outputs "out")))
+               (substitute* "rules/64-btrfs.rules.in"
+                 (("@bindir@")
+                  (string-append out "/bin")))
+               #t)))
          (add-after 'install 'move-static-library
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -2927,26 +2937,6 @@ device nodes from /dev/, handles hotplug events and loads drivers at boot
 time.")
     (license license:gpl2+)))
 
-;; TODO: Merge with eudev on the next rebuild cycle.
-(define-public eudev/btrfs-fix
-  (package/inherit
-   eudev
-   (version (string-append (package-version eudev) "-1"))
-   (arguments
-    (substitute-keyword-arguments (package-arguments eudev)
-      ((#:phases phases '%standard-phases)
-       `(modify-phases ,phases
-          (add-before 'configure 'patch-bindir-in-btrfs-rules
-            (lambda* (#:key outputs #:allow-other-keys)
-              ;; The "@bindir@" substitution incorrectly expands to a literal
-              ;; "${exec_prefix}" (see <https://bugs.gnu.org/39926>).  Work
-              ;; around it.
-              (let ((out (assoc-ref outputs "out")))
-                (substitute* "rules/64-btrfs.rules.in"
-                  (("@bindir@")
-                   (string-append out "/bin")))
-                #t)))))))))
-
 (define-public eudev-with-hwdb
   (deprecated-package "eudev-with-hwdb" eudev))