summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-08-25 20:33:53 -0400
committerLeo Famulari <leo@famulari.name>2022-08-31 15:00:45 -0400
commit58ff4553289a47f1b97b44eddef2e85a113d3652 (patch)
tree597732cf504af8623e2d521dff26833a14f7f569 /gnu/packages/linux.scm
parent3f3abddeeebd75987686e3735a4f3454494a95b9 (diff)
downloadguix-58ff4553289a47f1b97b44eddef2e85a113d3652.tar.gz
gnu: Add linux-libre 5.19.
* gnu/packages/linux.scm (linux-libre-5.19-version,
linux-libre-5.19-gnu-revision, deblob-scripts-5.19,
linux-libre-5.19-pristine-source, linux-libre-5.19-source,
linux-libre-headers-5.19, linux-libre-5.19): New variables.
* gnu/packages/aux-files/linux-libre/5.19-arm.conf,
gnu/packages/aux-files/linux-libre/5.19-arm64.conf,
gnu/packages/aux-files/linux-libre/5.19-i686.conf,
gnu/packages/aux-files/linux-libre/5.19-x86_64.conf: New files.
* Makefile.am (AUX_FILES): Add them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ba9e820c88..01fb79bf08 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -353,6 +353,22 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
 ;; The current "stable" kernels. That is, the most recently released major
 ;; versions that are still supported upstream.
 
+(define-public linux-libre-5.19-version "5.19.5")
+(define-public linux-libre-5.19-gnu-revision "gnu")
+(define deblob-scripts-5.19
+  (linux-libre-deblob-scripts
+   linux-libre-5.19-version
+   linux-libre-5.19-gnu-revision
+   (base32 "0a4pln89nbxiniykm14kyqmnn79gfgj22dr3h94w917xhidq7gp1")
+   (base32 "1ph67fvg5qvlkh4cynrrmvkngkb0sw6k90b1mwy9466s24khn05i")))
+(define-public linux-libre-5.19-pristine-source
+  (let ((version linux-libre-5.19-version)
+        (hash (base32 "1g9p4m9w9y0y1gk6vzqvsxzwqspbm10mmhd8n1mhal1yz721qgwc")))
+   (make-linux-libre-source version
+                            (%upstream-linux-source version hash)
+                            deblob-scripts-5.19)))
+
+
 (define-public linux-libre-5.18-version "5.18.19")
 (define-public linux-libre-5.18-gnu-revision "gnu")
 (define deblob-scripts-5.18
@@ -365,7 +381,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
   (let ((version linux-libre-5.18-version)
         (hash (base32 "1mc8zhiw0v7fka64mydpdrxkrvy0jyqggq5lghw3pyqj2wjrpw6z")))
    (make-linux-libre-source version
-
                             (%upstream-linux-source version hash)
                             deblob-scripts-5.18)))
 
@@ -490,6 +505,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (patches (append (origin-patches source)
                      patches))))
 
+(define-public linux-libre-5.19-source
+  (source-with-patches linux-libre-5.19-pristine-source
+                       (list %boot-logo-patch
+                             %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
 (define-public linux-libre-5.18-source
   (source-with-patches linux-libre-5.18-pristine-source
                        (list %boot-logo-patch
@@ -604,6 +624,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (description "Headers of the Linux-Libre kernel.")
     (license license:gpl2)))
 
+(define-public linux-libre-headers-5.19
+  (make-linux-libre-headers* linux-libre-5.19-version
+                             linux-libre-5.19-gnu-revision
+                             linux-libre-5.19-source))
+
 (define-public linux-libre-headers-5.18
   (make-linux-libre-headers* linux-libre-5.18-version
                              linux-libre-5.18-gnu-revision
@@ -925,6 +950,13 @@ It has been modified to remove all non-free binary blobs.")
 ;;; Generic kernel packages.
 ;;;
 
+(define-public linux-libre-5.19
+  (make-linux-libre* linux-libre-5.19-version
+                     linux-libre-5.19-gnu-revision
+                     linux-libre-5.19-source
+                     '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
+                     #:configuration-file kernel-config))
+
 (define-public linux-libre-5.18
   (make-linux-libre* linux-libre-5.18-version
                      linux-libre-5.18-gnu-revision