summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2022-06-11 10:50:39 +0300
committerLudovic Courtès <ludo@gnu.org>2022-06-16 12:50:05 +0200
commitc48c69cfa34868527e099c6d12458dfa222d010f (patch)
tree030489b1272c7553bdf0191051753535db54fe0a /gnu/packages/linux.scm
parentef2d908e22f9d4f4a89782766b67d425935ae4eb (diff)
downloadguix-c48c69cfa34868527e099c6d12458dfa222d010f.tar.gz
gnu: libtree: Update to 3.1.1.
* gnu/packages/linux.scm (libtree): Update to 3.1.1.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 216dd01395..7a9a6d183f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9199,7 +9199,7 @@ older system-wide @file{/sys} interface.")
 (define-public libtree
   (package
     (name "libtree")
-    (version "3.0.2")
+    (version "3.1.1")
     (source
      (origin
        (method git-fetch)
@@ -9208,7 +9208,7 @@ older system-wide @file{/sys} interface.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "072624anz9g01mp5vfkahfmzy0nb7axg5rwk3n1yrdm4hr3d4zrb"))))
+        (base32 "1jbc60cslzcfxk9jwva51ncr1zl1nz0fkgfjdckgv81is11nswmb"))))
     (arguments
      (list #:make-flags
            ;; NOTE: Official documentation recommends to build libtree with
@@ -9217,6 +9217,15 @@ older system-wide @file{/sys} interface.")
                    (string-append "PREFIX=" #$output))
            #:phases
            #~(modify-phases %standard-phases
+               (add-after 'unpack 'fix-tests
+                 ;; XXX: '08_nodeflib' fails as 'libtree' returns a non-zero
+                 ;; code in one of the tests.
+                 ;;
+                 ;; See <https://github.com/haampie/libtree/issues/80>).
+                 (lambda _
+                   (substitute* "tests/08_nodeflib/Makefile"
+                     (("! ../../libtree -vvv exe_b")
+                      "../../libtree -vvv exe_b"))))
                (delete 'configure))))
     (build-system gnu-build-system)
     (home-page "https://github.com/haampie/libtree")