summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-19 17:05:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-19 23:45:57 +0100
commitae67d70daa72f628cb06ccb2af5616f1876736d3 (patch)
tree25dfceefb57c0bdcb0b49bf0701abf8c706de291 /gnu/packages/linux.scm
parent3351f42acfa1c3e0ebdf5538a8b873304bf20ade (diff)
downloadguix-ae67d70daa72f628cb06ccb2af5616f1876736d3.tar.gz
gnu: rng-tools: Update to 6.7.
* gnu/packages/linux.scm (rng-tools): Update to 6.7.
[arguments]: Add ‘--without-pkcs11’ to #:configure-flags to avoid a new
dependeny on libp11.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 33ab24ad9c..c32f95b08e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3699,7 +3699,7 @@ The collection contains a set of bandwidth and latency benchmark such as:
   (package
     (name "rng-tools")
     (home-page "https://github.com/nhorman/rng-tools")
-    (version "6.6")
+    (version "6.7")
     (source (origin
               (method git-fetch)
               (uri (git-reference (url home-page)
@@ -3707,11 +3707,12 @@ The collection contains a set of bandwidth and latency benchmark such as:
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0c32sxfvngdjzfmxn5ngc5yxwi8ij3yl216nhzyz9r31qi3m14v7"))))
+                "19f75m6mzg8h7b4snzg7d6ypvkz6nq32lrpi9ja95gqz4wsd18a5"))))
     (build-system gnu-build-system)
     (arguments
      `(;; Avoid using OpenSSL, curl, and libxml2, reducing the closure by 166 MiB.
-       #:configure-flags '("--without-nistbeacon")))
+       #:configure-flags '("--without-nistbeacon"
+                           "--without-pkcs11")))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)