summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-10 09:07:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-10 11:10:08 +0200
commitc06d8ba5ee60427af4273b8ca1e02f4447b0db37 (patch)
treebfbb10235abc8efc7669fb7f5355e33d1340b862 /gnu/packages/linux.scm
parent0f1adf454d5fa96291b94dbdbd34640b8c581116 (diff)
downloadguix-c06d8ba5ee60427af4273b8ca1e02f4447b0db37.tar.gz
gnu: net-tools-for-tests: Remove variable.
* gnu/packages/linux.scm (net-tools-for-tests): Remove variable.
* gnu/packages/tls.scm (gnutls)[native-inputs]: Replace
net-tools-for-tests with net-tools.
[disallowed-references]: Remove field.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 0 insertions, 14 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 17dd0daafd..a16c488d9f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1185,17 +1185,6 @@ primary network configuration tools, but ifconfig is known to behave
 inadequately in modern network environments, and both should be deprecated.")
     (license license:gpl2+)))
 
-;; There are two packages for net-tools. The first, net-tools, can be used
-;; directly on the command-line or when it will be referenced by a built
-;; package. The second, net-tools-for-tests, can be used in package test suites
-;; if it is not referred to by the built package. Net-tools-for-tests may be
-;; relatively old and buggy. It should never be referred to by a built package.
-;; Use #:disallowed-references to enforce this.
-;;
-;; When we are able to rebuild many packages (i.e. core-updates), we can update
-;; net-tools-for-tests if appropriate.
-;;
-;; See <https://bugs.gnu.org/27811> for more information.
 (define-public net-tools
   ;; XXX: This package is basically unmaintained, but it provides a few
   ;; commands not yet provided by Inetutils, such as 'route', so we have to
@@ -1271,9 +1260,6 @@ network hardware types (plipconfig, slattach) and advanced aspects of IP
 configuration (iptunnel, ipmaddr).")
       (license license:gpl2+))))
 
-(define-public net-tools-for-tests
-  (hidden-package (package (inherit net-tools))))
-
 (define-public libcap
   (package
     (name "libcap")