summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-12-13 23:43:47 -0500
committerMark H Weaver <mhw@netris.org>2016-12-14 03:27:26 -0500
commit5a3849443ac8bdcffea0376b3c7efa30688c10bb (patch)
tree7cd384b5df8d008b9b2b043f97020cae46de5f43 /gnu/packages/linux.scm
parent4fbd0f4f86df30b6522260f727b39eaa8a3d1e52 (diff)
downloadguix-5a3849443ac8bdcffea0376b3c7efa30688c10bb.tar.gz
gnu: linux-libre: Update to 4.9.
* gnu/packages/linux.scm (%linux-libre-version, %linux-libre-hash)
(linux-libre): Update to 4.9.
* gnu/packages/linux-libre-4.8-x86_64.conf,
gnu/packages/linux-libre-4.8-i686.conf: Delete files.
* gnu/packages/linux-libre-4.9-x86_64.conf,
gnu/packages/linux-libre-4.9-i686.conf: New files.
* Makefile.am (KCONFIGS): Update accordingly.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1dab68a20f..2d006efe0b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -327,8 +327,8 @@ It has been modified to remove all non-free binary blobs.")
 (define %intel-compatible-systems '("x86_64-linux" "i686-linux"))
 
 (define-public linux-libre
-  (make-linux-libre "4.8.14"
-                    "06rh1j2m4x6kv7prgg2pakw81b7w75dxrl31ch1psf44yqy51q6q"
+  (make-linux-libre "4.9"
+                    "1x23853hjgsxqayvwlsw0555735s17hrrl7py13waqydwjw3k400"
                     %intel-compatible-systems
                     #:configuration-file kernel-config))
 
@@ -345,8 +345,8 @@ It has been modified to remove all non-free binary blobs.")
                     #:configuration-file kernel-config))
 
 ;; Avoid rebuilding kernel variants when there is a minor version bump.
-(define %linux-libre-version "4.8.14")
-(define %linux-libre-hash "06rh1j2m4x6kv7prgg2pakw81b7w75dxrl31ch1psf44yqy51q6q")
+(define %linux-libre-version "4.9")
+(define %linux-libre-hash "1x23853hjgsxqayvwlsw0555735s17hrrl7py13waqydwjw3k400")
 
 (define-public linux-libre-arm-generic
   (make-linux-libre %linux-libre-version