summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-05-10 16:17:21 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-10 16:44:01 +0200
commit75f796bb73a4cb4a06955fac19ef9af6f126988d (patch)
treec8f45681974bbe2bbb3e513183bf01c3450d4761 /gnu/packages/linux.scm
parentb047a86b6ce9f953034df1198ad73dcd223aaa3f (diff)
downloadguix-75f796bb73a4cb4a06955fac19ef9af6f126988d.tar.gz
gnu: e2fsprogs: Enable tests.
* gnu/packages/linux.scm (e2fsprogs)[native-inputs]: Add PERL and PROCPS.
[arguments]<#:tests?>: Remove.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index eb7c5d14ae..61c960bfbe 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -659,7 +659,11 @@ slabtop, and skill.")
     (build-system gnu-build-system)
     (inputs `(("util-linux" ,util-linux)))
     (native-inputs `(("pkg-config" ,pkg-config)
-                     ("texinfo" ,texinfo)))     ;for the libext2fs Info manual
+                     ("texinfo" ,texinfo)       ;for the libext2fs Info manual
+
+                     ;; For tests.
+                     ("perl" ,perl)
+                     ("procps" ,procps)))
     (arguments
      '(;; util-linux is the preferred source for some of the libraries and
        ;; commands, so disable them (see, e.g.,
@@ -710,12 +714,7 @@ slabtop, and skill.")
                         (for-each (lambda (file)
                                     (chmod file #o666))
                                   archives)
-                        #t))))))
-
-       ;; FIXME: Tests work by comparing the stdout/stderr of programs, that
-       ;; they fail because we get an extra line that says "Can't check if
-       ;; file system is mounted due to missing mtab file".
-       #:tests? #f))
+                        #t))))))))
     (home-page "http://e2fsprogs.sourceforge.net/")
     (synopsis "Creating and checking ext2/ext3/ext4 file systems")
     (description