summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2023-11-09 15:57:36 +0100
committerLeo Famulari <leo@famulari.name>2023-07-23 22:26:01 -0400
commitb817d261e2f9addba594583e154e4d9b6a850928 (patch)
treebbefa2e10c96e2b141876bf5e6ba381a962ca342 /gnu/packages/linux.scm
parent8074235a7e820ab6dd61179be3f73bf7ef85b1aa (diff)
downloadguix-b817d261e2f9addba594583e154e4d9b6a850928.tar.gz
gnu: Add linux-libre 6.6.1.
* gnu/packages/linux.scm (linux-libre-6.6-version, linux-libre-6.6-gnu-revision,
deblob-scripts-6.6, linux-libre-6.6-pristine-source, linux-libre-6.5-source,
linux-libre-headers-6.6, linux-libre-6.6): New variables.
* gnu/packages/aux-files/linux-libre/6.6-arm.conf,
gnu/packages/aux-files/linux-libre/6.6-arm64.conf,
gnu/packages/aux-files/linux-libre/6.6-i686.conf,
gnu/packages/aux-files/linux-libre/6.6-x86_64.conf: New files.
* Makefile.am (AUX_FILES): Add them.

Change-Id: I37b2b98b8a2ec745137e92380f34e69082c5e662
Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index dd237e755a..641d1cd113 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -493,6 +493,21 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
 ;; The current "stable" kernels. That is, the most recently released major
 ;; versions that are still supported upstream.
 
+(define-public linux-libre-6.6-version "6.6.1")
+(define-public linux-libre-6.6-gnu-revision "gnu")
+(define deblob-scripts-6.6
+  (linux-libre-deblob-scripts
+   linux-libre-6.6-version
+   linux-libre-6.6-gnu-revision
+   (base32 "0g8m0rb15b0231dv8ji456s75a67szsaim71may3yprplycz6pav")
+   (base32 "1hg3ck1j8288fhlhcvhgs1zzwh3i62nfvphw7x3vsaqr75kiwbjp")))
+(define-public linux-libre-6.6-pristine-source
+  (let ((version linux-libre-6.6-version)
+        (hash (base32 "0d42b1hbvv9w3y3q4wydr6il0g5a823n54a06p4p5vcpgkadf7ns")))
+   (make-linux-libre-source version
+                            (%upstream-linux-source version hash)
+                            deblob-scripts-6.6)))
+
 (define-public linux-libre-6.5-version "6.5.11")
 (define-public linux-libre-6.5-gnu-revision "gnu")
 (define deblob-scripts-6.5
@@ -629,6 +644,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (patches (append (origin-patches source)
                      patches))))
 
+(define-public linux-libre-6.6-source
+  (source-with-patches linux-libre-6.6-pristine-source
+                       (list %boot-logo-patch
+                             %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
 (define-public linux-libre-6.5-source
   (source-with-patches linux-libre-6.5-pristine-source
                        (list %boot-logo-patch
@@ -748,6 +768,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
     (description "Headers of the Linux-Libre kernel.")
     (license license:gpl2)))
 
+(define-public linux-libre-headers-6.6
+  (make-linux-libre-headers* linux-libre-6.6-version
+                             linux-libre-6.6-gnu-revision
+                             linux-libre-6.6-source))
+
 (define-public linux-libre-headers-6.5
   (make-linux-libre-headers* linux-libre-6.5-version
                              linux-libre-6.5-gnu-revision
@@ -1092,6 +1117,14 @@ Linux kernel.  It has been modified to remove all non-free binary blobs.")
 ;;; Generic kernel packages.
 ;;;
 
+(define-public linux-libre-6.6
+  (make-linux-libre* linux-libre-6.6-version
+                     linux-libre-6.6-gnu-revision
+                     linux-libre-6.6-source
+                     '("x86_64-linux" "i686-linux" "armhf-linux"
+                       "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
+                     #:configuration-file kernel-config))
+
 (define-public linux-libre-6.5
   (make-linux-libre* linux-libre-6.5-version
                      linux-libre-6.5-gnu-revision