summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-10 23:48:41 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-10 23:48:41 +0100
commit0750452a98c83e92d155a8ec9710d57a427040b9 (patch)
treef4358241c8327a660f44729180256c0d6879b74d /gnu/packages/linux.scm
parent65d8b777c0834cd3f2931b7c49254a7e943b06fc (diff)
downloadguix-0750452a98c83e92d155a8ec9710d57a427040b9.tar.gz
gnu: Add e2fsprogs.
* gnu/packages/linux.scm (e2fsprogs): New variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4d51d8b310..58cddc0d1c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -257,3 +257,42 @@ slabtop, and skill.")
     (description
      "Tools for working with USB devices, such as lsusb.")
     (license gpl2+)))
+
+(define-public e2fsprogs
+  (package
+    (name "e2fsprogs")
+    (version "1.42.7")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://sourceforge/e2fsprogs/e2fsprogs-"
+                                 version ".tar.gz"))
+             (sha256
+              (base32
+               "0ibkkvp6kan0hn0d1anq4n2md70j5gcm7mwna515w82xwyr02rfw"))))
+    (build-system gnu-build-system)
+    (inputs `(("util-linux" ,util-linux)
+              ("pkg-config" ,pkg-config)))
+    (arguments
+     '(#:phases (alist-cons-before
+                 'configure 'patch-shells
+                 (lambda _
+                   (substitute* "configure"
+                     (("/bin/sh (.*)parse-types.sh" _ dir)
+                      (string-append (which "sh") " " dir
+                                     "parse-types.sh")))
+                   (substitute* (find-files "." "^Makefile.in$")
+                     (("#!/bin/sh")
+                      (string-append "#!" (which "sh")))))
+                 %standard-phases)
+
+       ;; FIXME: Tests work by comparing the stdout/stderr of programs, that
+       ;; they fail because we get an extra line that says "Can't check if
+       ;; filesystem is mounted due to missing mtab file".
+       #:tests? #f))
+    (home-page "http://e2fsprogs.sourceforge.net/")
+    (synopsis "Tools for creating and checking ext2/ext3/ext4 filesystems")
+    (description
+     "This package provides tools for manipulating ext2/ext3/ext4 file systems.")
+    (license (list gpl2                           ; programs
+                   lgpl2.0                        ; libext2fs
+                   x11))))                        ; libuuid