summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-12 22:01:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-16 06:10:06 +0300
commit2f9e312a39618461b2efce0020e306fc3c112950 (patch)
tree09bc63c138e750be2c98b4b63766de25bea3544f /gnu/packages/linux.scm
parent30897c60a4bb54936c228daf46e26377306da280 (diff)
downloadguix-2f9e312a39618461b2efce0020e306fc3c112950.tar.gz
gnu: iw: Update to 4.3.
* gnu/packages/linux.scm (iw): Update to 4.3.
[source]: Use kernel mirror.
[home-page]: Update to new home-page.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 48f7499453..84deae706f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1168,15 +1168,15 @@ configuration and monitoring interfaces.")
 (define-public iw
   (package
     (name "iw")
-    (version "3.17")
+    (version "4.3")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "https://www.kernel.org/pub/software/network/iw/iw-"
+                    "mirror://kernel.org/software/network/iw/iw-"
                     version ".tar.xz"))
               (sha256
                (base32
-                "14zsapqhivk0ws5z21y1ys2c2czi05mzk7bl2yb7qxcfrnsjx9j8"))))
+                "085jyvrxzarvn5jl0fk618jjxy50nqx7ifngszc4jxk6a4ddibd6"))))
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs `(("libnl" ,libnl)))
@@ -1184,11 +1184,11 @@ configuration and monitoring interfaces.")
      `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
                           "CC=gcc")
        #:phases (alist-delete 'configure %standard-phases)))
-    (home-page "http://wireless.kernel.org/en/users/Documentation/iw")
+    (home-page "https://wireless.wiki.kernel.org/")
     (synopsis "Tool for configuring wireless devices")
     (description
      "iw is a new nl80211 based CLI configuration utility for wireless
-devices.  It replaces 'iwconfig', which is deprecated.")
+devices.  It replaces @code{iwconfig}, which is deprecated.")
     (license license:isc)))
 
 (define-public powertop