summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-03 03:57:53 -0400
committerLeo Famulari <leo@famulari.name>2016-10-06 17:43:39 -0400
commit3afbc6b3c3a78dddbb92651854bc0c8574078cdc (patch)
tree4088c39b759b7537d0c254c8ed4d847242eeecf8 /gnu/packages/linux.scm
parentaf0ba938255bb412ad021c19e651e632abd0103c (diff)
downloadguix-3afbc6b3c3a78dddbb92651854bc0c8574078cdc.tar.gz
gnu: lvm2: Use 'modify-phases'.
* gnu/packages/linux.scm (lvm2)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 52c7c7d027..66583dd253 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1661,16 +1661,17 @@ time.")
     (inputs
      `(("udev" ,eudev)))
     (arguments
-     '(#:phases (alist-cons-after
-                 'configure 'set-makefile-shell
-                 (lambda _
-                   ;; Use 'sh', not 'bash', so that '. lib/utils.sh' works as
-                   ;; expected.
-                   (setenv "SHELL" (which "sh"))
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'configure 'set-makefile-shell
+           (lambda _
+             ;; Use 'sh', not 'bash', so that '. lib/utils.sh' works as
+             ;; expected.
+             (setenv "SHELL" (which "sh"))
 
-                   ;; Replace /bin/sh with the right file name.
-                   (patch-makefile-SHELL "make.tmpl"))
-                 %standard-phases)
+             ;; Replace /bin/sh with the right file name.
+             (patch-makefile-SHELL "make.tmpl")
+             #t)))
 
        #:configure-flags (list (string-append "--sysconfdir="
                                               (assoc-ref %outputs "out")