summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-03 04:26:17 -0400
committerLeo Famulari <leo@famulari.name>2016-10-06 17:43:44 -0400
commit7ca97fae366b5ac8324a774d8aa09c2a36348666 (patch)
treed9e7288665aceb1f1a7caf3c07262c24c93f48fc /gnu/packages/linux.scm
parent123c0ffb87b0e921bc0e4fc4c46aec9439a7b538 (diff)
downloadguix-7ca97fae366b5ac8324a774d8aa09c2a36348666.tar.gz
gnu: lvm2: Make sure compiled objects are stripped.
* gnu/packages/linux.scm (lvm2)[arguments]: Add 'make-objects-writeable' phase.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 431e73dcf9..0e9fab25ee 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1671,7 +1671,17 @@ time.")
 
              ;; Replace /bin/sh with the right file name.
              (patch-makefile-SHELL "make.tmpl")
-             #t)))
+             #t))
+         (add-before 'strip 'make-objects-writable
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Make compiled objects writable so they can be stripped.
+             (let ((out (assoc-ref outputs "out")))
+               (for-each (lambda (file)
+                           (chmod file #o755))
+                         (append
+                           (find-files (string-append out "/lib"))
+                           (find-files (string-append out "/sbin"))))
+               #t))))
 
        #:configure-flags (list (string-append "--sysconfdir="
                                               (assoc-ref %outputs "out")