summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-01 22:02:12 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-01 22:16:40 +0300
commit5f7b070e97d0833e96ba1b0a7bb883d034467dc2 (patch)
treec3f73ad0359042e38f9f8e5e615ddd0df7808847 /gnu/packages/linux.scm
parent60bf81541cd9c35f3382e10fa6e86d44a932a850 (diff)
downloadguix-5f7b070e97d0833e96ba1b0a7bb883d034467dc2.tar.gz
gnu: bluez: Ungraft package.
* gnu/packages/linux.scm (bluez)[replacement]: Remove field.
[source]: Add patch.
(bluez/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm18
1 files changed, 2 insertions, 16 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8ef7a105d3..77e4963dca 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3027,7 +3027,6 @@ Bluetooth audio output devices like headphones or loudspeakers.")
   (package
     (name "bluez")
     (version "5.45")
-    (replacement bluez/fixed)
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -3035,7 +3034,8 @@ Bluetooth audio output devices like headphones or loudspeakers.")
                     version ".tar.xz"))
               (sha256
                (base32
-                "1sb4aflgyrl7apricjipa8wx95qm69yja0lmn2f19g560c3v1b2c"))))
+                "1sb4aflgyrl7apricjipa8wx95qm69yja0lmn2f19g560c3v1b2c"))
+              (patches (search-patches "bluez-CVE-2017-1000250.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
@@ -3089,20 +3089,6 @@ Bluetooth audio output devices like headphones or loudspeakers.")
 is flexible, efficient and uses a modular implementation.")
     (license license:gpl2+)))
 
-(define bluez/fixed
-  (package
-    (inherit bluez)
-    (version "5.45")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "mirror://kernel.org/linux/bluetooth/bluez-"
-                    version ".tar.xz"))
-              (sha256
-               (base32
-                "1sb4aflgyrl7apricjipa8wx95qm69yja0lmn2f19g560c3v1b2c"))
-              (patches (search-patches "bluez-CVE-2017-1000250.patch"))))))
-
 (define-public fuse-exfat
   (package
     (name "fuse-exfat")