summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-26 01:29:21 -0500
committerLeo Famulari <leo@famulari.name>2015-12-29 14:20:55 -0500
commitb7e7d1b9d3121f057e71e17e1ead645d123ee335 (patch)
treea78c038b65a9ff090e05bf7acfbd3e8e2c488d6d /gnu/packages/linux.scm
parentc7d0bf0071306bc996b0584190a85b9859fdead9 (diff)
downloadguix-b7e7d1b9d3121f057e71e17e1ead645d123ee335.tar.gz
gnu: fuse: Update to 2.9.4.
* gnu/packages/patches/fuse-CVE-2015-3202.patch: Delete file.
* gnu-system.am (dist_patch_DATA): Remove it.
* gnu/packages/linux.scm (fuse): Update to 2.9.4.
  [source]: Remove patch.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1fc3c4e45f..fcae17b609 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1242,15 +1242,18 @@ processes currently causing I/O.")
 (define-public fuse
   (package
     (name "fuse")
-    (version "2.9.3")
+    (version "2.9.4")
     (source (origin
               (method url-fetch)
-              (uri (string-append "mirror://sourceforge/fuse/fuse-"
-                                  version ".tar.gz"))
+              (uri (let ((version-with-underscores
+                          (string-join (string-split version #\.) "_")))
+                     (string-append
+                       "https://github.com/libfuse/libfuse/"
+                       "releases/download/" version-with-underscores
+                       "/fuse-" version ".tar.gz")))
               (sha256
                (base32
-                "071r6xjgssy8vwdn6m28qq1bqxsd2bphcd2mzhq0grf5ybm87sqb"))
-              (patches (list (search-patch "fuse-CVE-2015-3202.patch")))))
+                "1qbwp63a2bp0bchabkwiyzszi9x5krlk2pwk2is6g35gyszw1sbb"))))
     (build-system gnu-build-system)
     (inputs `(("util-linux" ,util-linux)))
     (arguments