summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-04-04 11:31:11 -0400
committerMark H Weaver <mhw@netris.org>2015-04-05 23:03:21 -0400
commit025523f1e4c0eb4583b709b9c97dda850817591f (patch)
tree1b5231e38414900b5877c1941c2f311dd145ee12 /gnu/packages/linux.scm
parentf2ca414acb80769423fcd864dbca02f6a10e4183 (diff)
downloadguix-025523f1e4c0eb4583b709b9c97dda850817591f.tar.gz
gnu: linux-libre: Fix drm_wait_one_vblank warnings.
* gnu/packages/patches/linux-libre-vblank-fix.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/linux.scm (linux-libre)[source]: Add patch.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 089ef588b2..637cde9f69 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -273,7 +273,8 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
               (base32
                "13nq0wzkjy7hrhnnvxlwzs1awlqd81vzriqddjn6s9ma3fzj44bn"))
              (patches
-              (list (search-patch "linux-libre-libreboot-fix.patch")))))
+              (list (search-patch "linux-libre-libreboot-fix.patch")
+                    (search-patch "linux-libre-vblank-fix.patch")))))
     (build-system gnu-build-system)
     (native-inputs `(("perl" ,perl)
                      ("bc" ,bc)