summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-11-03 15:15:23 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2017-11-06 19:55:10 +0100
commitf6948189a940c0bf354672141762c6dacf1395e1 (patch)
treefc1ba1ffefa51afc7be2fb5d321ab92d3e744a41 /gnu/packages/linux.scm
parent2ac42fe51fcbd9b9f36fcfce350da2d483dc0cc9 (diff)
downloadguix-f6948189a940c0bf354672141762c6dacf1395e1.tar.gz
linux: Add omap2plus generic kernel.
* gnu/packages/linux.scm (linux-libre-arm-omap2plus): New exported variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2ecf6bdfd3..0ee2d601ad 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -402,6 +402,13 @@ It has been modified to remove all non-free binary blobs.")
                     #:defconfig "multi_v7_defconfig"
                     #:extra-version "arm-generic"))
 
+(define-public linux-libre-arm-omap2plus
+  (make-linux-libre %linux-libre-version
+                    %linux-libre-hash
+                    '("armhf-linux")
+                    #:defconfig "omap2plus_defconfig"
+                    #:extra-version "arm-omap2plus"))
+
 
 ;;;
 ;;; Pluggable authentication modules (PAM).