summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-11 04:42:02 -0400
committerMark H Weaver <mhw@netris.org>2018-04-11 15:04:45 -0400
commitc5bd8753be4521eab22935551efc9d8ccfb9f177 (patch)
tree1e8dec91cc8a112509149c4e662403e4b5b739f1 /gnu/packages/linux.scm
parent0d91cd07a21c5708bbc57bbb7d8469b744c7bba7 (diff)
downloadguix-c5bd8753be4521eab22935551efc9d8ccfb9f177.tar.gz
gnu: linux-libre: Add 'patch-/bin/pwd' phase.
* gnu/packages/linux.scm (make-linux-libre)[arguments]: Add 'patch-/bin/pwd'
phase.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e774dbb3a0..c24f024898 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -311,6 +311,11 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
                   (ice-9 match))
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch-/bin/pwd
+           (lambda _
+             (substitute* (find-files "." "^Makefile(\\.include)?$")
+               (("/bin/pwd") "pwd"))
+             #t))
          (replace 'configure
            (lambda* (#:key inputs native-inputs target #:allow-other-keys)
              ;; Avoid introducing timestamps