summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-07 10:31:45 +0200
committerLudovic Courtès <ludo@gnu.org>2014-10-07 10:31:45 +0200
commiteb564fc389f23ae21a1bf07f6c9f4f454a4abbe3 (patch)
tree259e39856d27de5da435b3a0ce8f6293987e6219 /gnu/packages/linux.scm
parentcb90e7e0ebc407e204a76930d36b77a289acc57e (diff)
downloadguix-eb564fc389f23ae21a1bf07f6c9f4f454a4abbe3.tar.gz
gnu: eudev: Really update to 1.10.
* gnu/packages/linux.scm (eudev)[version]: Fix typo.
  [source]: Add 'snippet'.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6d9073d063..37324f9bb3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1387,7 +1387,7 @@ time.")
   ;; The post-systemd fork, maintained by Gentoo.
   (package (inherit udev)
     (name "eudev")
-    (version "1.`0")
+    (version "1.10")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -1396,7 +1396,16 @@ time.")
               (sha256
                (base32
                 "1l907bvz6dcykvaq8d4iklvfpb9fyrnh1a29g3c28gkx2hlyn7j0"))
-              (patches (list (search-patch "eudev-rules-directory.patch")))))
+              (patches (list (search-patch "eudev-rules-directory.patch")))
+              (modules '((guix build utils)))
+              (snippet
+               ;; 'configure' checks uses <linux/btrfs.h> as an indication of
+               ;; whether Linux headers are available, but it doesn't actually
+               ;; use it, and our 'linux-libre-headers' package doesn't
+               ;; provide it.  So just remove that.
+               '(substitute* "configure"
+                  (("linux/btrfs\\.h")
+                   "")))))
     (arguments
      (substitute-keyword-arguments (package-arguments udev)
        ((#:configure-flags flags)