summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-11-29 12:52:59 +0800
committerLudovic Courtès <ludo@gnu.org>2014-11-29 22:34:58 +0100
commitec01f22d15067c80eb673aba3edb49cf7913f187 (patch)
treee02cf35dffb319555888899ed5599d1d67d56149 /gnu/packages/linux.scm
parent7dfc937e2f06e16e1f66599168bdcc45dde10d46 (diff)
downloadguix-ec01f22d15067c80eb673aba3edb49cf7913f187.tar.gz
gnu: wireless-tools: Install the manual pages under $out/share/man.
* gnu/packages/linux.scm (wireless-tools)[origin]: Add snippet.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b9d9bd68c9..0651c08f91 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1487,7 +1487,13 @@ mapper.  Kernel components are part of Linux-libre.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0qscyd44jmhs4k32ggp107hlym1pcyjzihiai48xs7xzib4wbndb"))))
+                "0qscyd44jmhs4k32ggp107hlym1pcyjzihiai48xs7xzib4wbndb"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; Install the manual pages in the right place.
+               '(substitute* "Makefile"
+                  (("INSTALL_MAN= .*")
+                   "INSTALL_MAN= $(PREFIX)/share/man")))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases (alist-replace