summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-11-07 18:01:37 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2017-11-09 20:35:11 +0100
commitcfbe7b7f4ccdb61534b47d91fe8e43db2ee1737d (patch)
tree7a792833e8bed373af77888607767df6b98f4580 /gnu/packages/linux.scm
parent3694a9b33be5c977567ede2d8e23a8159bdb344c (diff)
downloadguix-cfbe7b7f4ccdb61534b47d91fe8e43db2ee1737d.tar.gz
gnu: linux: Add linux-libre arm kernel.
* Makefile.am (AUX_FILES): Add arm config file.
* gnu/packages/aux-files/linux-libre/4.13-arm.conf: New file.
* gnu/packages/linux.scm (%intel-compatible-systems): Rename to
  %linux-compatible-systems and add "armhf-linux".
  (linux-libre): Adapt consequently.

The config file for arm is taken from debian armmp kernel. It's a generic
firmware for ARMv7 multiplatform compatible SoCs.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ce7c220e0b..441063343f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -366,15 +366,19 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
 It has been modified to remove all non-free binary blobs.")
     (license license:gpl2)))
 
-(define %intel-compatible-systems '("x86_64-linux" "i686-linux"))
+(define %linux-compatible-systems '("x86_64-linux" "i686-linux" "armhf-linux"))
 
 (define %linux-libre-version "4.13.11")
 (define %linux-libre-hash "1x2q80s27qcp3skjhqb36xhhcnrjgsq49g7l1ggc3rb3f9cshm59")
 
+;; linux-libre configuration for armhf-linux is derived from Debian armmp.  It
+;; supports qemu "virt" machine and possibly a large number of ARM boards.
+;; See : https://wiki.debian.org/DebianKernel/ARMMP.
+
 (define-public linux-libre
   (make-linux-libre %linux-libre-version
                     %linux-libre-hash
-                    %intel-compatible-systems
+                    %linux-compatible-systems
                     #:configuration-file kernel-config))
 
 (define-public linux-libre-4.9