summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-23 00:52:27 -0400
committerMark H Weaver <mhw@netris.org>2015-06-23 02:53:00 -0400
commitf3457e7001c44b4455d80c6d44ec92a761c87d6c (patch)
treeeb8a34b551f0ac092a16404b62afd2e186d56bf5 /gnu/packages/linux.scm
parentb7a3cf11a8e35299df52a15c9739c12a21e00c14 (diff)
downloadguix-f3457e7001c44b4455d80c6d44ec92a761c87d6c.tar.gz
gnu: linux-libre: Update to 4.1.
* gnu/packages/linux.scm (linux-libre): Update to 4.1.
  [inputs]: Remove gcc-4.9, since it is now the default compiler.
* gnu/packages/linux-libre-i686.conf, gnu/packages/linux-libre-x86_64.conf:
  Update to 4.1 configs from <https://jxself.org/git/?p=kernel-configs.git>.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 986a51a46a..34316d4d9d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -210,7 +210,7 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
      #f)))
 
 (define-public linux-libre
-  (let* ((version "4.0.5")
+  (let* ((version "4.1")
          (build-phase
           '(lambda* (#:key system inputs #:allow-other-keys #:rest args)
              ;; Apply the neat patch.
@@ -283,7 +283,7 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
              (uri (linux-libre-urls version))
              (sha256
               (base32
-               "0g8a4h8gjw51pp02hjfrp6bk2nkrclm3krp9mpjh3iwbf4vfh2al"))))
+               "092kfpch3j6v06vn88rvvdkjhnzbx1w73rh5nbf0n2kx0zmfbcj8"))))
     (build-system gnu-build-system)
     (native-inputs `(("perl" ,perl)
                      ("bc" ,bc)
@@ -295,11 +295,6 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
                          (if conf
                              `(("kconfig" ,conf))
                              '()))))
-
-    ;; XXX: Work around an ICE with our patched GCC 4.8.3 while compiling
-    ;; 'drivers/staging/vt6656/michael.o': <http://hydra.gnu.org/build/96389/>.
-    (inputs `(("gcc" ,gcc-4.9)))
-
     (arguments
      `(#:modules ((guix build gnu-build-system)
                   (guix build utils)