summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-04 14:37:53 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-04 14:37:53 +0200
commitb15389e15958dcfdd6a321ab635233b74b9ea630 (patch)
tree741a5ce390bb3915a7dca3c52ed8343ded5cd111 /gnu/packages/linux.scm
parent67dfa1986d7e8af9a42ffa7c9d2b40599857cf19 (diff)
downloadguix-b15389e15958dcfdd6a321ab635233b74b9ea630.tar.gz
gnu: linux-libre-headers: Do not retain reference to the bootstrap tools.
* gnu/packages/linux.scm (linux-libre-headers)[install-phase]: Remove
  ".install" files from the output.
  [arguments]: Add #:allowed-references.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm22
1 files changed, 16 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2232e8611e..262c5bdb34 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -106,12 +106,21 @@
                (and (zero? (system* "make"
                                     (string-append "INSTALL_HDR_PATH=" out)
                                     "headers_install"))
-                    (mkdir (string-append out "/include/config"))
-                    (call-with-output-file
-                        (string-append out
-                                       "/include/config/kernel.release")
-                      (lambda (p)
-                        (format p "~a-default~%" ,version))))))))
+                    (begin
+                      (mkdir (string-append out "/include/config"))
+                      (call-with-output-file
+                          (string-append out
+                                         "/include/config/kernel.release")
+                        (lambda (p)
+                          (format p "~a-default~%" ,version)))
+
+                      ;; Remove the '.install' and '..install.cmd' files; the
+                      ;; latter contains store paths, which pulls in bootstrap
+                      ;; binaries in the build environment, and prevents bit
+                      ;; reproducibility for the bootstrap binaries.
+                      (for-each delete-file (find-files out "\\.install"))
+
+                      #t))))))
    (package
     (name "linux-libre-headers")
     (version version)
@@ -133,6 +142,7 @@
                  (alist-replace
                   'install ,install-phase
                   (alist-delete 'configure %standard-phases)))
+       #:allowed-references ()
        #:tests? #f))
     (synopsis "GNU Linux-Libre kernel headers")
     (description "Headers of the Linux-Libre kernel.")