summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2019-03-18 03:24:05 +0000
committerLudovic Courtès <ludo@gnu.org>2019-04-03 18:21:42 +0200
commit1dbb9302c204c33d2d3b306065419d48596fe5cd (patch)
tree74dc3b64f22191357fa4e3688c38bd3a1e9491c3 /gnu/packages/linux.scm
parentbfac63667552898b32821c0f0fae1256f5bcab0c (diff)
downloadguix-1dbb9302c204c33d2d3b306065419d48596fe5cd.tar.gz
gnu: Add linux-libre-arm-veyron.
* gnu/packages/linux (linux-libre-arm-veyron): New variable.
  (kernel-config-veyron): function to find veyron config.
* gnu/packages/aux-files/linux-libre/5.0-arm-veyron.conf: New file.
* Makefile.am (AUX_FILES): Adjust accordingly.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9e4261eb02..d547fb37b6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -254,6 +254,15 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
          (file (string-append "linux-libre/" name)))
     (search-auxiliary-file file)))
 
+;; FIXME: merge into kernel-config
+(define* (kernel-config-veyron arch #:key variant)
+  "Return the absolute file name of the Linux-Libre build configuration file
+for ARCH and optionally VARIANT, or #f if there is no such configuration."
+  (let* ((name (string-append (if variant (string-append variant "-") "")
+                              (if (string=? "i386" arch) "i686" arch) "-veyron.conf"))
+         (file (string-append "linux-libre/" name)))
+    (search-auxiliary-file file)))
+
 (define %default-extra-linux-options
   `(;; https://lists.gnu.org/archive/html/guix-devel/2014-04/msg00039.html
     ("CONFIG_DEVPTS_MULTIPLE_INSTANCES" . #t)
@@ -472,6 +481,14 @@ It has been modified to remove all non-free binary blobs.")
                     #:defconfig "multi_v7_defconfig"
                     #:extra-version "arm-generic"))
 
+(define-public linux-libre-arm-veyron
+  (make-linux-libre %linux-libre-version
+                    %linux-libre-hash
+                    '("armhf-linux")
+                    #:patches %linux-libre-5.0-patches
+                    #:configuration-file kernel-config-veyron
+                    #:extra-version "arm-veyron"))
+
 (define-public linux-libre-arm-generic-4.19
   (make-linux-libre %linux-libre-4.19-version
                     %linux-libre-4.19-hash