summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-16 20:56:20 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-16 20:56:20 +0200
commita43fe7acd1bbe9dd5118d7bff823f4730153cc48 (patch)
tree3ed0f2e7c152b1e877d2725f23b17cc5189f92af /gnu/packages/linux.scm
parent5c4aa84e4ab891ae2cfc10b8601113887550c070 (diff)
downloadguix-a43fe7acd1bbe9dd5118d7bff823f4730153cc48.tar.gz
gnu: multipath-tools: Enable tests.
* gnu/packages/linux.scm (multipath-tools)[arguments]: Remove #:tests?.  Add
 #:test-target.  Add phase to add missing linker flag.
[native-inputs]: Add CMOCKA.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2d8acea0e3..aa52068794 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4205,7 +4205,7 @@ arrays when needed.")
                   #t))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f                      ; no tests
+     '(#:test-target "test"
        #:parallel-build? #f             ;XXX: broken in 0.8.4
        #:make-flags (list "CC=gcc"
                           (string-append "DESTDIR="
@@ -4242,11 +4242,22 @@ arrays when needed.")
                (("bool is_queueing;")
                 "bool is_queueing = false;"))
              #t))
+         (add-after 'unpack 'fix-linking-tests
+           (lambda _
+             ;; Add missing linker flag for -lmpathcmd.  This should be fixed
+             ;; for versions > 0.8.4.
+             (substitute* "tests/Makefile"
+               (("-lmultipath -lcmocka")
+                "-lmultipath -L$(mpathcmddir) -lmpathcmd -lcmocka"))
+             #t))
          (delete 'configure))))         ; no configure script
     (native-inputs
      `(("perl" ,perl)
        ("pkg-config" ,pkg-config)
-       ("valgrind" ,valgrind)))
+       ("valgrind" ,valgrind)
+
+       ;; For tests.
+       ("cmocka" ,cmocka)))
     (inputs
      `(("json-c" ,json-c)
        ("libaio" ,libaio)