summary refs log tree commit diff
path: root/gnu/packages/lirc.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-01-15 01:00:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-01-15 01:00:00 +0100
commitec3226c3985d5ec168d45499f12dfcf87f0f5c94 (patch)
tree764a5906bed626737fd5b59066cd3ac0393fb3c1 /gnu/packages/lirc.scm
parentea37595a7c71a430b0d1a2c860b9b0e37ec126bd (diff)
downloadguix-ec3226c3985d5ec168d45499f12dfcf87f0f5c94.tar.gz
gnu: lirc: Update to 0.10.2.
* gnu/packages/lirc.scm (lirc): Update to 0.10.2.
[arguments]: Add a new 'build-reproducibly phase to partially replace…
* gnu/packages/patches/lirc-reproducible-build.patch: …this updated file.
Diffstat (limited to 'gnu/packages/lirc.scm')
-rw-r--r--gnu/packages/lirc.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/lirc.scm b/gnu/packages/lirc.scm
index 58d63cbdab..a2e542b2ce 100644
--- a/gnu/packages/lirc.scm
+++ b/gnu/packages/lirc.scm
@@ -38,14 +38,14 @@
 (define-public lirc
   (package
     (name "lirc")
-    (version "0.10.1")
+    (version "0.10.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/lirc/LIRC/" version
                                   "/lirc-" version ".tar.bz2"))
               (sha256
                (base32
-                "1whlyifvvc7w04ahq07nnk1h18wc8j7c6wnvlb6mszravxh3qxcb"))
+                "0ai27l6hxfgkwvkqa3fy1b1gqzw2y10md030y5ig4748fj1fqi1x"))
               (patches (search-patches "lirc-localstatedir.patch"
                                        "lirc-reproducible-build.patch"))))
     (build-system gnu-build-system)
@@ -91,7 +91,10 @@
            (lambda _
              (substitute* "Makefile.in"
                (("(PYTHON_TARBALL.*=).*" _ tarball=)
-                (string-append tarball= "\n"))))))))
+                (string-append tarball= "\n")))))
+         (add-before 'configure 'build-reproducibly
+           (lambda _
+             (setenv "LIRC_IRDB_CACHE_ID" "build time"))))))
     (native-inputs
      (list pkg-config libxslt))
     (inputs