summary refs log tree commit diff
path: root/gnu/packages/lirc.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-03-22 16:23:47 +0300
committerAlex Kost <alezost@gmail.com>2015-03-26 15:47:39 +0300
commite7682771686e2aa90bf4c244a6995db21d0070ae (patch)
tree92a735f88cec0a2bf2a098ce0f60408fc6e1b21e /gnu/packages/lirc.scm
parentaad6f5bcda28bd598f4937df8f97e651b4a97e8f (diff)
downloadguix-e7682771686e2aa90bf4c244a6995db21d0070ae.tar.gz
gnu: Add LIRC.
* gnu/packages/lirc.scm: New file.
* gnu/packages/patches/lirc-localstatedir.patch: New file.
* gnu-system.am: Add them.
Diffstat (limited to 'gnu/packages/lirc.scm')
-rw-r--r--gnu/packages/lirc.scm61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnu/packages/lirc.scm b/gnu/packages/lirc.scm
new file mode 100644
index 0000000000..c070e1aaa4
--- /dev/null
+++ b/gnu/packages/lirc.scm
@@ -0,0 +1,61 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages lirc)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages linux)
+  #:use-module (gnu packages xorg)
+  #:use-module (gnu packages python))
+
+(define-public lirc
+  (package
+    (name "lirc")
+    (version "0.9.2a")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/lirc/lirc-"
+                                  version ".tar.bz2"))
+              (sha256
+               (base32
+                "011nwpxm5d12rsapljg3pjf9pgb0j8ngmc3zg69q4kv61hkx2zim"))
+              (patches (list (search-patch "lirc-localstatedir.patch")))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags '("--localstatedir=/var")))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libx11" ,libx11)
+       ("alsa-lib" ,alsa-lib)
+       ("python" ,python)))
+    (home-page "http://www.lirc.org/")
+    (synopsis "Linux Infrared Remote Control")
+    (description
+     "LIRC allows computers to send and receive IR signals of many commonly
+used remote controls.  The most important part of LIRC is the 'lircd' daemon
+that decodes IR signals received by the device drivers.  The second daemon
+program 'lircmd' allows to translate IR signals to mouse movements.  The
+user space applications allow you to control your computer with a remote
+control: you can send X events to applications, start programs and much more
+on just one button press.")
+    (license license:gpl2+)))