summary refs log tree commit diff
path: root/gnu/packages/lisp-check.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/lisp-check.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running:

  ./pre-inst-env guix style

without any additional argument.
Diffstat (limited to 'gnu/packages/lisp-check.scm')
-rw-r--r--gnu/packages/lisp-check.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index a66a7ba47e..9a37bdcfbf 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -82,7 +82,7 @@
          ("closer-mop" ,sbcl-closer-mop)
          ("optima" ,sbcl-optima)))
       (native-inputs
-       `(("stefil" ,sbcl-stefil)))
+       (list sbcl-stefil))
       (home-page "https://github.com/arclanguage/Clamp")
       (synopsis "Randomized specification-based testing for Common Lisp")
       (description
@@ -120,9 +120,9 @@ designed to embed randomized tests in whatever framework you like.")
        '(#:asd-files '("checkl.asd")
          #:tests? #f))
       (native-inputs
-       `(("sbcl-fiveam" ,sbcl-fiveam)))
+       (list sbcl-fiveam))
       (inputs
-       `(("sbcl-marshal" ,sbcl-marshal)))
+       (list sbcl-marshal))
       (home-page "https://github.com/rpav/CheckL/")
       (synopsis "Dynamic testing for Common Lisp")
       (description
@@ -160,7 +160,7 @@ against the last run.")
          ("closer-mop" ,sbcl-closer-mop)
          ("trivia" ,sbcl-trivia)))
       (native-inputs
-       `(("fiveam" ,sbcl-fiveam)))
+       (list sbcl-fiveam))
       (home-page "https://github.com/Ferada/cl-mock")
       (synopsis "Mocking functions for Common Lisp testing")
       (description
@@ -381,9 +381,9 @@ interactive development model in mind.")
          (file-name (git-file-name "hu.dwim.stefil" version))))
       (build-system asdf-build-system/sbcl)
       (native-inputs
-       `(("asdf:cl-hu.dwim.asdf" ,sbcl-hu.dwim.asdf)))
+       (list sbcl-hu.dwim.asdf))
       (inputs
-       `(("sbcl-alexandria" ,sbcl-alexandria)))
+       (list sbcl-alexandria))
       (home-page "http://dwim.hu/project/hu.dwim.stefil")
       (synopsis "Simple test framework")
       (description "Stefil is a simple test framework for Common Lisp,